century21.com - performing search gives error dialog and null results with non-Firefox UA

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
1) Go to century21.com
2) Type in any zipcode or city/state
3) Hit the find button
4) Next page loads but no results are shown, an error box is display saying "VRNetwork.GetExecutionID is not a function". 

Works in in IE7
This is caused by defective User Agent sniffing code on the site.  Works fine if I utilize the User Agent Switcher add-on to change the user agent string to either:

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20070627 Firefox/2.0

or:

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/20070627 Firefox/3.0
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Comment 2

10 years ago
This works fine in Camino branch builds. What app is this bug being reported against?
This fails with Firefox trunk builds using the default user agent string.  That is the application this was originally reported on.

Comment 4

10 years ago
I don't know why Camino branch is working -- it should be doing the same thing Firefox would if you removed the "firefox" from the UA string -- but regardless, there's definitely a UA-specific sniffer at work there:

https://realogy.infusiondev.com/appliancetoolkits/v1/jslibrary/CommonObjects/CommonObjects.js

   function isFirefox()
   {      
      var ffv = 0;
      var ffn = "Firefox/"
      var ffp = navigator.userAgent.indexOf(ffn);
      if (ffp != -1) 
         ffv = parseFloat(navigator.userAgent.substring(ffp + ffn.length));
         
      if(ffv>0)
         return true;
      else
         return false;
   }

That's not the only sniffing code they use, but it's the only sniffing code they use that I could find that appears to give different code to Firefox vs. non-Firefox Gecko browsers.

http://www.century21.com/js/global.js

contains a much smarter sniffer that doesn't look like it's to blame for this problem.
Blocks: 334967
OS: Windows XP → All
Hardware: PC → All
Summary: Century21.com search results in error dialog/no matches display → century21.com - performing search gives error dialog and null results with non-Firefox UA
i have also found many sites using sniffer code that does not like the 'a8pre' at the end of the gecko version or application version very much either.  I don't know if that applies here.

Comment 6

10 years ago
Please file additional TE bugs on those (or, if it's one common JS library at fault, against the library itself) and we can try to get something accomplished.

cl
(Reporter)

Comment 7

10 years ago
Any luck on contacting century 21?  Just wondering since its been 4 months and still can not use century 21.
(Reporter)

Comment 8

8 years ago
Century21 has redone their page and I can no longer reproduce this.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 9

8 years ago
Yep, looks like it's FIXED here, too.
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.