Events marked "all day" get exported to successive days.

VERIFIED DUPLICATE of bug 357272

Status

VERIFIED DUPLICATE of bug 357272
11 years ago
11 years ago

People

(Reporter: pbagrow, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Lightning 0.5 (build 2007062404)

I marked an event (Son's Birthday) as "all day" because there is no time associated with it and I didn't want "6:00 AM Son's Birthday" to show on the calender.

I export my calender as an iCalendar (.ics) file in order to import with BitPim v1.0.1.  When I import to BitPim, "Son's Birthday" shows up on the correct day AND the next day.

I viewed the .ics file with notepad and found the DTEND line for my event has the next day as the end date.

I can edit the .ics file, changing my event to end on the same day and save.  I import this to BitPim and it works.  But I don' want to go through my whole .ics file and change all my date/time groups.

SOLUTION

Is is possible to code an event marked "all day" to end at 2359, so it will not occupy the next day's date/time. 

Thanks for listening,

Paul Bagrow
Win 2000
Firefox 2.0.0.6
Thunderbird 2.0.0.6
Lightning 0.5

Reproducible: Always

Steps to Reproduce:
1. Create event and mark as "all day"
2. Export as iCalendar.ics file
3. Import as iCalendar file to BitPim 1.0.1
4. See event on two consecutive days.
Actual Results:  
Event is shown on consecutive days using BitPim

Expected Results:  
Event should show only on the original scheduled day.
See previous discussion on this topic in Bug 357272.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357272

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.