bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

When Syncked Lightning with Google Calender, Cannot acesses send mail option from lightning.

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Sunny, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Thunderbird (Latest- 2.0), Latest Lightning

When Syncked Lightning with Google Calender, Cannot acesses send mail option from lightning.This only hapens when used with the Provider Google add ons.

Reproducible: Always

Steps to Reproduce:
1.Sync Lightining with Goolge calender with Provider Goole ad ons.
2.Create an Event in Lightning, send email option is greyed out.
3.
With Latest Lightning you mean Lightning 0.5 or Lightning 0.7pre? What build?

As far as I know the Gdata provider doesn't support sending invitations via Thunderbird because invitations will be handled directly via Google Calendar (Bug 355226).
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> With Latest Lightning you mean Lightning 0.5 or Lightning 0.7pre? What build?
> 
> As far as I know the Gdata provider doesn't support sending invitations via
> Thunderbird because invitations will be handled directly via Google Calendar
> (Bug 355226).
> 
The Version used is Lightning 0.5, I would as well check on Lightning 0.7pre also. I belive instead of using Addons from Gdata provider, if I use Gcaldeamon, I think I should be able to sync my calender as well send emails also. we have ten users in our comapny and don't know if this would be a good option. Any suggestion would be greatly apprecianle. 
As a workaround, you could try to 

* open the xpi
* open the jar file in the chrome folder
* open calGoogleCalendar.js
* locate sendItipInvitations
* Change false to true

I have no idea how this affects the provider, but it should allow you to send invitations per email. Otherwise, try a nightly build (with a 0.7pre lightning/sunbird). It has more attendee support, as seen in bug 355226.

I have no opinion to gcaldaemon, since I haven't tried it.
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> As a workaround, you could try to 
> * open the xpi
> * open the jar file in the chrome folder
> * open calGoogleCalendar.js
> * locate sendItipInvitations
> * Change false to true
> I have no idea how this affects the provider, but it should allow you to send
> invitations per email. Otherwise, try a nightly build (with a 0.7pre
> lightning/sunbird). It has more attendee support, as seen in bug 355226.
> I have no opinion to gcaldaemon, since I haven't tried it.

Where can I download Lightning 0.7pre??
You can get it from ftp.mozilla.org. Note however you need to build a CVS version of the gdata provider, or wait until bug 393853 has been resolved.
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> You can get it from ftp.mozilla.org. Note however you need to build a CVS
> version of the gdata provider, or wait until bug 393853 has been resolved.
> 
I tried using the ligthning 0.7 preversion (got from the location http://weblogs.mozillazine.org/rumblingedge/archives/2007/09/20070903_sunbird_07_builds.html)  but the result is not good. My google calender is syncing properly, but the same events are not visible in lightning. You could add and send invitations, but its a dummy invitation, the receipent is not receiving any invitations.Thanks. 
Did you also use a CVS version of the gdata provider?
(Reporter)

Comment 8

11 years ago
No did not, I would try to search for that version gdata provider. Would  it be possible to send me a down loadble link or a location where i could find that version. Thanks in advance for you support.
There is currently no official CVS build. See bug 393853. I'll post a temporary link there.
(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> There is currently no official CVS build. See bug 393853. I'll post a temporary
> link there.
> 

Down loaded, tested and works perfect. Thanks you very much.

Regards,
Sunil.
Resolving WFM per comment #10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.