Closed Bug 39382 Opened 20 years ago Closed 19 years ago

Build fails if --disable-shared is used on OpenBSD.

Categories

(SeaMonkey :: Build Config, defect, P4)

x86
OpenBSD
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 46775

People

(Reporter: mozillaBugzilla, Assigned: cls)

Details

When compiling under OpenBSD, the build fails with:

c++  -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
-Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth -Wshadow -pedantic
-Wno-long-long -pthread -g -o regExport regExport.o  -L../../../dist/bin
-L../../../dist/lib -lxpcomds_s -lmozreg_s /usr/local/lib/libgtk.a
/usr/local/lib/libgdk.a /usr/local/lib/libgmodule.a /usr/local/lib/libglib.a
-L/usr/local/lib -L/usr/X11R6/lib  -lintl -lXext -lX11 -lm -L../../../dist/bin
-lplds4 -lplc4 -lnspr4 -lc_r -L../../../dist/bin -lxpcom  -lutil -lm   
ld: -lxpcom: no match
collect2: ld returned 1 exit status
gmake[3]: *** [regExport] Error 1
gmake[3]: Leaving directory `/.disk1/src/mozilla/xpcom/tools/registry'
gmake[2]: *** [install] Error 2
gmake[2]: Leaving directory `/.disk1/src/mozilla/xpcom/tools'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/.disk1/src/mozilla/xpcom'
gmake: *** [install] Error 2

My .mozconfig file:
# sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#

# Options for client.mk.
mk_add_options MOZ_CVS_FLAGS="-q -z 9"
#mk_add_options MOZ_MAKE_FLAGS=-j4

# Options for 'configure' (same as command-line options).
#ac_add_options --disable-mailnews
ac_add_options --disable-tests
#ac_add_options --enable-optimize
#ac_add_options --disable-debug
#ac_add_options --enable-strip-libs
#ac_add_options --enable-mathml
#ac_add_options --enable-svg
ac_add_options --disable-shared
ac_add_options --with-static-gtk

I managed to build the tree without --disable-shared and --with-static-gtk
--disable-shared may be terminally broken.  Mozilla pretty much requires you to
be able to load dynamically linked libraries.  There have been several instances
where just using a static version of libstdc++ has been known to cause problems
much less trying to link the entire thing statically.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P3 → P4
Target Milestone: --- → M25
According to Bug# 36467 OpenBSD has a problem with it's dynamic linker, so I
tried to build a static version out of desperation.
Status: NEW → ASSIGNED
Changing OS to new OpenBSD field. :)
OS: other → OpenBSD

*** This bug has been marked as a duplicate of 46775 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.