no-cache pages on hicksdesign.co.uk require force-reload to see changes

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: alqahira, Unassigned)

Tracking

Details

(URL)

STR:

1. Visit hicksdesign and read the comments on any journal item; remember how many comments there were.
2. Come back to the same journal item page tomorrow and wonder why no one else has commented.
3. Shift-reload and watch the comments appear!

I think I've also repro'd this by leaving a comment and coming back to the page, but I don't often have something to say.  I do see this every time Hicks writes a new post, which is about fortnightly, but I keep forgetting to file this.

smokey% curl -I http://www.hicksdesign.co.uk/journal/a-plea-for-a-decent-cuppa
HTTP/1.1 200 OK
Date: Mon, 27 Aug 2007 05:32:50 GMT
Server: Apache on SegPub
Last-Modified: Sun, 26 Aug 2007 22:12:24 GMT
Cache-Control: no-cache
Vary: Accept-Encoding
X-Powered-By: SegPub
Content-Type: text/html; charset=utf-8

Comment 1

11 years ago
I suspect Textpattern is partly to blame here (as I know, it does set headers).
When looking at it with LiveHttpHeaders on Minefield latest, I see lots of contradictory info/headers

first load: HTTP/1.x 200 OK
an hour later (from History): HTTP/1.x 304 Not Modified
but the page _was_ modified

Over the 2 hours I tested this, I needed once to force reload to see changes, and twice a reload was sufficient (both Camino trunk and Minefield suffered from this).

And sorry to Mr Hicks for the abuse of bandwidth.

(and I can't reproduce this with my local install of Texpattern. I use the latest SVN rev, though, and possibly different settings).
This sounds like a site bug, then, and not a Camino one, if I'm understanding philippe correctly?
Summary: no-cache pages on Hicks's website require force-reload to see changes → no-cache pages on hicksdesign.co.uk require force-reload to see changes
I'm not seeing this this week, so WFM (though it might have been INVALID).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.