Lightning does not show events in the calendar view

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Evgueny Antonoff, Unassigned)

Tracking

Details

(Whiteboard: [0.5 disappearing events])

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Thunderbird version 2.0.0.6 (20070728), Lightning nightly 26-Aug-2007 05:32

Thunderbird version 2.0.0.6 (20070728), Lightning nightly 26-Aug-2007 05:32
(just got it from the /pub)

I use two calendars as external .ics files on my local hard drive. There are events and some tasks in both of them.

After upgrading from nightly from Aug14, 2007, to latest nightly 26-Aug-2007 05:32, the events are not shown in the calendar view (please see the screenshots - they'll explain maybe better)

Reproduced:
- restarted thunderbird - bug reproduces
- downgraded to my old nightly (the quoted version) - everything is ok
- upgraded again to the latest nightly - bug reproduces

Reproducible: Always

Steps to Reproduce:
1. have some calendar events in your calendar
2. upgrade to latest nightly build 26-Aug-2007 05:32 as in 
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-mozilla1.8/windows-xpi/


Actual Results:  
see your calendar - there should not be any events there

Expected Results:  
there should be all events/tasks in the calendar as user entered them
(Reporter)

Comment 1

11 years ago
Created attachment 278384 [details]
Screenshot with the old build - there is no problem
(Reporter)

Comment 2

11 years ago
Created attachment 278385 [details]
Screenshot with the latest build - here is the bug - no events are shown
(Reporter)

Comment 3

11 years ago
Did additional testing: The last windows build where the bug did not appear was found:
2007-08-23-06-mozilla1.8

The next tested build was:
2007-08-24-05-mozilla1.8

There the bug appeared. Hope this helps.
(Reporter)

Comment 5

11 years ago
Additional testing:

The bug did not appears IF user does upgrading build-by-build from the earlier quoted to the quoted latest.

What I did again was downgrading to Aug14, 2007, then back to latest in order to try re-producing the bug, with no success. 

I am not able to reproduce this bug anymore. But hope someone else could go deeper.

Still dont have error messages in the console (calendar.debug.log=true)
Severity: major → normal

Comment 6

11 years ago
I'm having the same exact issue with the nightly builds, only I'm using the Google Data provider (GData) instead of local iCalendar files. I attempted what Evgueny mentioned in Comment:5, but I had no such luck of the bug being fixed.

I found that between the August 15, 2007 and the August 16, 2007 builds (and on) that the Google Data provider support breaks, and I cannot see _any_ of my events _anywhere_. This includes all views for any part of Lightning. 

Updated

11 years ago
Flags: blocking-calendar0.7+

Comment 7

11 years ago
Chris,
Google data provider is not compatible at the moment with recent nightlies. There will be a new version soon. See bug 392627.
And please only request for blocking status (?), don't approve blocking (+).
Flags: blocking-calendar0.7+ → blocking-calendar0.7?

Updated

11 years ago
Whiteboard: [0.5 disappearing events]
Bug 393387 was fixed a few days ago and might help with the issue reported here too. I'd like you to retest with a Sunbird or Lightning 0.7pre (20070918) or newer build if your issue still exists.
(Reporter)

Comment 9

11 years ago
Upgraded to 2007-09-18-03-mozilla1.8 (winxp no wcap) and used it the whole day. Could not reproduce the bug. Will write again if this re-occurs, but for now seems fixed.

Keep it going guys!

PS: Don't know if I have the rights to mark the bug as WORKSFORME, so would leave it to someone from the company. Just curious - if the bug is working is it OK for the reporter to mark it as worksforme/invalid/fixed?
Thanks for testing. I'll resolve the bug WORKSFORME for you and add a dependency to Bug 393387. Please reopen if the issue reappears in a newer build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Depends on: 393387
Resolution: --- → WORKSFORME
Flags: blocking-calendar0.7?
You need to log in before you can comment on or make changes to this bug.