Sidebar starts empty in Linux m15

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: davor.cubranic, Assigned: slamm)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When I start m15, sidebar has four tabs, as it should (no customizations), but
they are all blank (each tab's name and content). Occasionally, there is stuff
in the content area that looks like parts of a window, like the repaint isn't
done correctly. Adding another tab through "customize" button, for MozillaZine,
revived the sidebar and it started working correctly. Up until I did that, the
bug was there every time I started the browser.

The following output in the terminal window may be helpful, because it
disappeared once the sidebar came back to life:

frame: Box[id=] (0x9187514) style: 0x9a67d10 {
  http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul|* weight: 0 {
display: 1[0x1]enum }
}
Wrong parent style context:  style: 0x940b7c8 {
  http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul|* weight: 0 {
display: 1[0x1]enum }
}
should be using:  style: 0x992c120 {
  http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul|* weight: 0 {
display: 1[0x1]enum }
}

Comment 1

19 years ago
This is no longer seen in m16 builds.Davor, pls check with a nightly build on 
mozilla.org. thnx!
(Reporter)

Comment 2

19 years ago
After a fresh reinstall and compile of M15, I don't see this behaviour any more.

Comment 3

19 years ago
resolving invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 4

18 years ago
ver
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.