Star icon shouldn't be set for items in RSS / Live Bookmarks.

VERIFIED FIXED in Firefox 3 alpha8

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: Dolske, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
Firefox 3 alpha8
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
When viewing a site from a Live Bookmark folder, the URL bar shows that star icon as turned on (yellow). This isn't really useful, because such feeds are ephemeral, and it's not really saved for future access. It's also a bit confusing to have sites suddenly appear to become bookmarked.
OS: Mac OS X → All
Hardware: PC → All
(In reply to comment #1)
> but note, I could not reproduce with:

A feed url that redirects to another URL, containing links that redirect from what's in the feed to different final URLs.
I was hoping to use something like the type column of moz_bookmarks, but that only tells me if the bookmark is a folder, separator, bookmark or dynamic container.  perhaps we need a new value, for a livemark item?

otherwise, we may have to check to see if the bookmark has a "livemark/bookmarkFeedURI" annotation to determine if it is a livemark item or not.

asaf / dietrich, thoughts?

note, this bug also shows up with bug #387718 (the location bar dropdown should show a star next to bookmarked results)
as part of his recent patch for bug #385266, asaf has a fix for this for the star button in the url bar, but for url bar autocomplete results (bug #387718), for performance reasons, checking if the bookmark's parent has an annotation of "livemark/feedURI" may not be performant enough.

for now, re-assign this bug to mano and I'll work about the url bar autocomplete result issue in bug #385266

Assignee: nobody → mano
Fixed in bug 385266.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M8
this doesn't appear to be fixed.

steps to reproduce:

1)  add http://weblogs.mozillazine.org/asa/index.rdf as a livebookmark
2)  refresh the livemark
3)  visit http://weblogs.mozillazine.org/asa/archives/2007/08/getting_involve.html

it appears bookmarked.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007083005 Minefield/3.0a8pre

re-opening.

(fwiw, see the second patch in bug #387718)

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
> fwiw, see the second patch in bug #387718

spun off to bug #394484
ok, the problem is with getMostRecentBookmarkForURI(), testing a fix.
Assignee: mano → sspitzer
Status: REOPENED → NEW
Created attachment 279164 [details] [diff] [review]
patch

when checking if we have the livemark annotation, check the bookmarks parent ("folder") and not the grandparent ("parent").

it might be a good idea to rename folder and parent to parent and grandparent.
Attachment #279164 - Flags: review?(mano)
Status: NEW → ASSIGNED
Flags: in-litmus?
Flags: blocking-firefox3?
Comment on attachment 279164 [details] [diff] [review]
patch

r=dietrich. please do make that naming fix to make things clearer.
Attachment #279164 - Flags: review?(mano) → review+
Comment on attachment 279164 [details] [diff] [review]
patch

sending review over to dietrich
Attachment #279164 - Flags: review+ → review?(dietrich)
Created attachment 279177 [details] [diff] [review]
patch as checked in (using parent and grandparent)

carrying over dietrich review
Attachment #279164 - Attachment is obsolete: true
Attachment #279177 - Flags: review+
Attachment #279164 - Flags: review?(dietrich)
fixed.

Checking in browser/components/places/content/utils.js;
/cvsroot/mozilla/browser/components/places/content/utils.js,v  <--  utils.js
new revision: 1.61; previous revision: 1.60
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
http://litmus.mozilla.org/show_test.cgi?id=4677

in-litmus+ (might be in the wrong subcategory, but we can always move it later)
Flags: in-litmus? → in-litmus+
Verified FIXED using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091204 Minefield/3.0a8pre

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007091204 Minefield/3.0a8pre

with the STR in comment 7.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.