If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

While typing text it's send to second, non-active tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Krzysztof Sieluzycki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

I had opened two tabs with online dictionaries. The pages were fully loaded. I had entered a word in first tab [in textbox activated by default on the site], but the page was loading slowly, so I've switched to the second tab. I've entered the word, but this page was loading slowly, too - so I have switched to first tab back [the page there was already loaded]. When I was entering the next word I realized I was typing in the second tab - I saw last typed words, but in the place of textbox on site on the second tab! I have pressed enter, and the site in the second tab refreshed; I have switched tabs and realized, I have really entered a word into non-active tab. I've tried more times - sometimes it happen, sometimes it does not. I think it's somethink with setting active textbox on the page, but only when the tabs are changed while site loads.

I think it can be a bit insecure sometimes, for example when you enter a password to a form without looking on the screen, and on the second tab you have another site, like chat or webmail client.


Reproducible: Sometimes

Steps to Reproduce:
1. Open two sites that have textboxes activated by default (I mean you can write in it immediately after site loads)
2. Enter sth in the textbox, while site is loading switch the tabs, enter sth in the textbox, and again - while the site is loading - switch the tabs again.
3. Probably You'll be able to write in the another, non-active tab. It happened to me 3 times when I've tried to reproduce it.
Actual Results:  
I'm able to type in textbox on site in non-active tab.

Expected Results:  
I shouldn't be able to type anythink to form that I think is not activated, because it's in non-active tab. It is an easy way to loose important information.

I have to apologize for my English level - I'm still learning.

Comment 1

10 years ago
Odd that the fixes for bug 124750 and bug 310825 (which were in Firefox 2) didn't work for you.

Do you see this bug if you use a Firefox 3 beta version?  We've changed a good bit of focus code since Firefox 2.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Odd that the fixes for bug 124750 and bug 310825 (which were in Firefox 2)
> didn't work for you.
> 
> Do you see this bug if you use a Firefox 3 beta version?  We've changed a good
> bit of focus code since Firefox 2.
> 

Now I use FF 2.0.0.11 and I don't see this bug. I think it's already fixed, I don't know why fixes for bugs 124750 and 310825 didn't worked for me - and because it was nearly half a year ago I don't remember the details.

Updated

10 years ago
Group: security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.