"Save As Web Page, Complete" fails/broken for local HTML files

VERIFIED FIXED in mozilla1.9beta1

Status

()

Toolkit
Downloads API
--
major
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Josh Aas, Assigned: Mardak)

Tracking

({regression})

Trunk
mozilla1.9beta1
regression
Points:
---
Bug Flags:
blocking1.9 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
1. open a simple HTML page
2. save it to your desktop as "Web Page, complete"
3. try to quit the browser

Result:
Warns about download in progress, asks if you want to cancel it. First of all, the download is done, secondly, I can't see any downloads in the download manager.
I see this too with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007082705 Minefield/3.0a8pre.  OS/Plat->All.
Severity: normal → major
Keywords: regression
OS: Mac OS X → All
Hardware: PC → All
Error: uncaught exception: [Exception... "Node was not found"  code: "8" nsresult: "0x80530008 (NS_ERROR_DOM_NOT_FOUND_ERR)"  location: "chrome://mozapps/content/downloads/downloads.js Line: 188"]
Stephen, what line is that roughly in the non-preprocessed file?
(In reply to comment #3)
> Stephen, what line is that roughly in the non-preprocessed file?

Bah; I think that error was from another build/bug I'm working with; sorry for the spam.  I actually don't seem to get any errors thrown (my bad).

Trying to find a regression range now, which would help us figure this out.
This regressed between 2007-08-15-05 (works) and 2007-08-16-05 (fails):

http://tinyurl.com/38tldc (checkin window)
Flags: in-litmus?
Changing summary to be more informative, from "can't see webpage complete download, also it never ends," to ""Save As Web Page, Complete" fails/broken for local HTML files."
Flags: blocking-firefox3?
Summary: can't see webpage complete download, also it never ends → "Save As Web Page, Complete" fails/broken for local HTML files
(Assignee)

Updated

11 years ago
Duplicate of this bug: 394646
(Assignee)

Comment 8

11 years ago
Saving works fine after applying bug 393821.
Depends on: 393821
Flags: blocking-firefox3? → blocking-firefox3+
Targeting M9 since Bug 393821 is (and has a patch that can land once dependencies are landed)
Assignee: nobody → edilee
Target Milestone: --- → Firefox 3 M9
moving out bugs that don't need to block b1
Target Milestone: Firefox 3 M9 → Firefox 3 M10
(Assignee)

Comment 11

11 years ago
Seems to be fixed by bug 393821 -- checked with an hourly build
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100120 Minefield/3.0a9pre

Tested with download manager closed before saving and download manager open when saving. Saved http://www.squarefree.com/start/ to a local file then opened the local html file and saved again.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3 M10 → Firefox 3 M9
Verified FIXED using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007100120 Minefield/3.0a9pre
Status: RESOLVED → VERIFIED
http://litmus.mozilla.org/show_test.cgi?id=4718

in-litmus+
Flags: in-litmus? → in-litmus+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.