[PP] Imagemaps don't work after clicking in text and paging back

VERIFIED DUPLICATE of bug 3836

Status

()

Core
Selection
P3
normal
VERIFIED DUPLICATE of bug 3836
19 years ago
18 years ago

People

(Reporter: Eli Goldberg, Assigned: mjudge)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
[PP] Imagemaps don't work after clicking in text and paging back

* STEPS TO REPRODUCE
0) Launch Apprunner
1) View a page with an image map (I used http://slip/projects/marvin/html/
image_usemap_01.html)
2) Locate the mouse pointer in a text block, and click the mouse button.
3) Press the "Back" button, returning you to the image map page.
4) Click anywhere on the imagemap

* RESULT
 - What happened

Mouse pointer doesn't turn into a hand, but remains a pointer. Imagemap clicks
not recognized.

If you move the mouse pointer near any text blocks, you'll see text highlighting,
implying that Communicator thinksit's in the middle of performing a text
selection.

(Also, while I can reproduce this problem 100% using the cited test case, I can't
reproduce this problem using the image map at www.apple.com.)

 - What was expected

Imagemap click to be recognized after back/forward/back button sequence.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (3.17.99 optimized build)

 - Doesn't Occur On
        Mac OS Viewer (3.17.99 optimized build)

        Win32 Apprunner (3.17.99 optimized build [NT 4, Service Pack 3])
        Linux Apprunner (3.17.99 optimized build)


* CONFIGURATIONS TESTED

- [Mac] Power Mac 8500/120 (233 Mhz 604e), 64 MB RAM (VM on; 1 MB of VM used),
1024x768 (Thousands of Colors), Mac OS 8.5.1

- [Win32] Vectra VL (233 Mhz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 Mhz P2), 96 MB RAM.
(Reporter)

Updated

19 years ago
QA Contact: 4130 → 1698
(Reporter)

Comment 1

19 years ago
Also, please note that this bug does not occur using the image_usemap_02,
image_usemap_03 or image_usemap_04 image map files in the same directory, either.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
this seems like pixley bug. but I will look at it.  I need to make some
architecture changes anyway.
(Assignee)

Comment 3

19 years ago
i need another url elig do you know where there is another html page i can test
this on?  the one mentioned does not exist anymore unfortunately. thanks man
(Reporter)

Comment 4

19 years ago
Hi, Mike ---

Oops. I've updated the URL field. There's also http://slip/projects/marvin/html/
image_usemap_gif.html.

[Also, FYI, as of the 5.17.99 AM build, I can no longer reproduce this issue on
Mac OS; haven't checked Win32/Linux, but can if desired.]
(Reporter)

Comment 5

19 years ago
DUH. Please ignore my comment about this working; I confused it with another bug.
It's definitely time for lunch...
(Reporter)

Comment 6

19 years ago
Oops. Step 1.5 is missing. Specifically: Click anywhere within the image map.

[I'm still seeing this problem on the 5.17.99 build; please let me know if you
need any help in reproducing; really easy.]
(Assignee)

Updated

19 years ago
Target Milestone: M8
(Assignee)

Comment 7

19 years ago
ok i see it now. stretch the window all the way out and the farther you get from
left margin the more "off" the Getposition code is. moving to m8 because i cant
look at this now
(Assignee)

Comment 8

19 years ago
ok i see it now. stretch the window all the way out and the farther you get from
left margin the more "off" the Getposition code is. moving to m8 because i cant
look at this now

Comment 9

19 years ago
Per a request from Selection and Search component eng (mjudge) and qa (elig),
moving all "Selection and Search" bugs to new "Selection" component.  Original
"Selection and Search" component will be retired.
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9
(Assignee)

Comment 10

19 years ago
bug not looked at still working on architecture changes for multiple types of
selection and also the lineup/linedown/closest line.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 11

19 years ago
*** This bug has been marked as a duplicate of 3836 ***
(Reporter)

Comment 12

19 years ago
Prove it. ;)
(Reporter)

Updated

19 years ago
Depends on: 3836
(Reporter)

Updated

19 years ago
Whiteboard: [7.28.99] Not verifying as duplicate until 3836 fixed.
(Reporter)

Updated

19 years ago
Whiteboard: [7.28.99] Not verifying as duplicate until 3836 fixed. → [8.9.99] Not verifying as duplicate until 3836 fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [8.9.99] Not verifying as duplicate until 3836 fixed. → [8.27.99] Not verifying as duplicate until 3836 fixed.
(Reporter)

Comment 13

19 years ago
[Rubber-stamping this bug as a "makes it easier for Mike to group bugs together
even if they're not quite the same thing" verified duplicate, since I'll be
checking this one upon verifying 3836.]
(Reporter)

Comment 14

18 years ago
Now that 3836 is fixed, I've confirmed that this bug is also in fact fixed using 
this morning's Mac OS Mozilla build.
Whiteboard: [8.27.99] Not verifying as duplicate until 3836 fixed.
You need to log in before you can comment on or make changes to this bug.