"All Bookmarks" selection option for Gold Star-added Bookmarks disappears

VERIFIED FIXED in Firefox 3 beta3

Status

()

Firefox
Bookmarks & History
P2
normal
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: abillings, Assigned: mano)

Tracking

Trunk
Firefox 3 beta3
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
If a user is on a web page and selects the star on the location bar, a bookmark is added for that page and the star turns gold. If the gold star is selected a second time, a dialog comes up which contains a field for the bookmark name, a drop down to select the folder the bookmark goes in, and a field for tags.

By default, when this dialog comes up, the folder dropdown is pre-selected with "All Bookmarks" as the containing folder. Two of the other options if the dropdown is selected are the Bookmarks Menu and the Bookmarks Toolbar. If either of these are selected and the dialog is dismissed by clicking on "done", the "All Bookmarks" option will never appear again when the dialog is opened in the future. This seems like a bug of some sort (either we should never see "All Bookmarks" or it should consistently be there).

Steps to Reproduce
1. Go to an unbookmarked page.
2. Select the star on the location bar. It will turn gold.
3. Select the star again.
4. In the dialog that opens, change "Folder" from "All Bookmarks" to "Bookmarks Menu".
5. Click the "Done" button.
6. Select the star again.
7. In the dialog, try changing the folder back to "All Bookmarks".

Result: "All Bookmarks" is no longer a folder option.
(Reporter)

Comment 1

11 years ago
Found in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007082704 Minefield/3.0a8pre.

Comment 2

10 years ago
Reproducible in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110616 Minefield/3.0a9pre

(In reply to comment #0)
> the "All Bookmarks" option will never appear again when the dialog is opened in
> the future.

This is true as long as the page remains bookmarked.  Deleting the bookmark first will allow you to re-bookmark the page in "All Bookmarks". Nevertheless, I agree this is a bug.
Flags: blocking-firefox3?
Mano: wanna look into this as you're doing the other special bookmark folder work?
Assignee: nobody → mano
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Target Milestone: --- → Firefox 3 M11
So, there's a bit of a mental model bustage here now that its "Unfiled Bookmarks" since its pretty hard to "unfile" something already filed, but we should just allow this.

Updated

10 years ago
Duplicate of this bug: 407475
Fixed by bug 401509.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 8

10 years ago
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
Gecko/2007121805 Minefield/3.0b3pre and the equivalent Mac nightly build. 
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.