on idle (once a day?) do a full vacuum to defragment places.sqlite

RESOLVED DUPLICATE of bug 395020

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 395020
10 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

on idle (once a day?) do a full vacuum to defragment places.sqlite

from the sqlite docs:

"Auto-vacuum does not defragment the database nor repack individual database pages the way that the VACUUM command does. In fact, because it moves pages around within the file, auto-vacuum can actually make fragmentation worse."

so we might want to do a full vacuum.

see related bug #390244 and bug #385834
sigh, a dup of my own bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395020
Duplicate of this bug: 506676
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

8 years ago
Blocks: 558460

Updated

8 years ago
No longer blocks: 558460
You need to log in before you can comment on or make changes to this bug.