quoted printable utf-8 in email subjects is unreadable

VERIFIED DUPLICATE of bug 387860

Status

()

Bugzilla
Email Notifications
VERIFIED DUPLICATE of bug 387860
10 years ago
10 years ago

People

(Reporter: fedor ezeev, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.21 (Windows NT 5.0; U; ru)
Build Identifier: 3.0

quoted printable utf-8 in email subjects is unreadable

Reproducible: Always

Steps to Reproduce:
1. Switch on utf-8 flag in bugzilla (run convert.pl and checksetup, as shown in docs)
2. Create new bug with non-english Summary
3. Comment to this bug with another user
4. Try to read subject of incoming mail
Actual Results:  
Something like this:
[ Ошибка 3170 ] Ð¢ÐµÑ Ñ‚Ð¾Ð²Ð°Ñ Ð·Ð°Ð´Ð°Ñ‡Ð° - http://cvs.alterplast.ru/bugs/show_bug.cgi?id=3170 Fedor Ezeev changed …

Expected Results:  
[Bug 3170] Тестовая задача - http://cvs.alterplast.ru/bugs/show_bug.cgi?id=3170 Fedor Ezeev changed …

At first, I was thinking this is a mail client problem.
But now I tested Outlook Express, Lotus Notes, gmail.com web interface and mail.ru (lead russian free mail site) web interface - and now I think this is a more complicated problem.

Part of mail source with Subject looked like this:

From: bugzilla@cvs.alterplast.ru
Message-Id: <200708291307.l7TD7I1M010237@cvs.alterplast.ru>
X-Authentication-Warning: cvs.alterplast.ru: nobody set sender to bugzilla-daemon using -f
To: myaddress@gmail.com
Subject: [
 
 =?UTF-8?Q?=C3=90=C2=9E=C3=91=C2=88=C3=90=C2=B8=C3=90=C2=B1=C3=90=C2=BA=C3=90=C2=B0=203170?=
 ]
 =?UTF-8?Q?=20=C3=90=C2=A2=C3=90=C2=B5=C3=91=C2=81=C3=91=C2=82=C3=90=C2=BE=C3=90=C2=B2=C3=90=C2=B0=C3=91=C2=8F=20=C3=90=C2=B7=C3=90?=
 =?UTF-8?Q?=C2=B0=C3=90=C2=B4=C3=90=C2=B0=C3=91=C2=87=C3=90=C2=B0?=
Content-Type: text/plain; charset="UTF-8"
X-Bugzilla-Reason: Reporter
X-Bugzilla-Type: newchanged
Unless I'm very much mistaken, this is a duplicate of bug 387860, which has been fixed in 3.0.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387860
(Reporter)

Comment 2

10 years ago
Yes, you are wright, i'm sorry.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.