overflow styles should not impact STATE_FOCUSABLE

RESOLVED DUPLICATE of bug 257938

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 257938
11 years ago
11 years ago

People

(Reporter: Joanmarie Diggs, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access})

Trunk
x86
Linux
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Steps to reproduce:

1. Use Accerciser to examine the states of the section in the attached test case.

Expected results: STATE_FOCUSABLE would not be present because the section is not a focusable object (i.e. it's just text).

Actual results: STATE_FOCUSABLE is present.

2. Edit the test case to remove the overflow:auto; style.  Re-examine the section in Accerciser.  Now STATE_FOCUSABLE is not present.

Note that overflow:scroll; also causes this behavior.
(Reporter)

Comment 1

11 years ago
Created attachment 278812 [details]
the test case I forgot to attach. :-)
(Reporter)

Comment 2

11 years ago
Aaron just pointed out bug #257938 to me.  Looks like this is a dup.  My apologies.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257938
You need to log in before you can comment on or make changes to this bug.