ui problems when attempting to run a .exe from the download manager on vista

VERIFIED DUPLICATE of bug 396635

Status

()

defect
VERIFIED DUPLICATE of bug 396635
12 years ago
11 years ago

People

(Reporter: moco, Unassigned)

Tracking

Trunk
mozilla1.9beta2
x86
Windows Vista
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

ui problems when attempting to run a .exe from the download manager on vista

1) on vista, attempt to download a firefox installer exe
2) after you download, click on the .exe in the download manager
3) you should get the uac prompt
4) if you cancel uac, you then get the firefox run prompt (is that correct?)
5) the run prompt is the wrong size, by default.

screen shot coming.

this is with:  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007082915 Minefield/3.0a8pre
Once I clicked Accept from the UAC prompt, the Moz Extractor kicked right in and starting extracting the build.  I did not see the 'select an application' box. 

Dirty profile
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007082905 Minefield/3.0a8pre Firefox/3.0 ID:2007082905

Vista HP
> Once I clicked Accept from the UAC prompt, the Moz Extractor kicked right in
> and starting extracting the build.

Jim, thanks for checking.  

I see the same thing as you when I accept the uac prompt, but do you see what I see when you cancel the uac prompt (in commment #0):  "4) if you cancel uac, you then get the firefox run prompt (is that correct?)"
Seth, 
Sorry, I missed that step, Yes.. I see the same pop-up asking for Application Box.

Litmus triage team: marcia and tomcat will cover this test case since is a cross os integration area.
This *might* be a duplicate, but it's pretty important, and it looks like we might be missing or ignoring sizeToContent() calls.
Flags: blocking-firefox3? → blocking-firefox3+
Hmm, what does Firefox 2 do in this case?
Target Milestone: --- → Firefox 3 M10
(In reply to comment #7)
> Hmm, what does Firefox 2 do in this case?

Firefox 2 lets you open (run) .exes, but it does so only from the download manager itself, not from the "Save as" dialog.  Double-clicking on the .exe in the DM throws up a warning dialog delineating the risks of running executables...
(In reply to comment #8)
> Isn't this a duplicate of bug 396635?
Yes, it is.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 396635
Verified dup
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.