If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

text-changed and state-changed events missing when an object is hidden

RESOLVED WORKSFORME

Status

()

Core
Disability Access APIs
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Joanmarie Diggs, Assigned: Joanmarie Diggs)

Tracking

(Blocks: 2 bugs, {access})

Trunk
x86
Linux
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

10 years ago
Steps to reproduce:

1. Search for a business at 411.com (e.g. Dominos Pizza in Huntsville, Alabama). 

2.  Launch Accerciser and turn event monitoring on.

3.  On the search results page, click on one of the "phone" links/buttons to show the phone number.

At this point a couple of things happen to the "phone" link:

1. The accessible text associated with the "phone" link is removed as evidenced by text.characterCount == 0 and text.getText(0, -1) == ""

2. The states change.  In particular the following states are removed:  FOCUSABLE, SHOWING, SENSITIVE, VISIBLE, (also HORIZONTAL and OPAQUE but these are not as significant).

There are no text-changed:delete events or state-changed events to announce these changes in the phone link.

Comment 1

10 years ago
I think you're holding onto an old link object that is no longer there. Is there no children-changed event saying that it goes away? Is it now DEFUNCT?

I think a new text object is being created in its place. Not sure yet what the JS is doing though.

Comment 2

10 years ago
Nevermind, you're right.

Updated

10 years ago
Blocks: 368895

Comment 3

10 years ago
Joanie,

I don't know where the "phone" links/buttons are.

Can you give me a screenshot or something?

Updated

10 years ago
Depends on: 396346

Updated

10 years ago
Blocks: 396346
No longer depends on: 396346
(Assignee)

Comment 4

10 years ago
Oh shoot, they changed that site.  That will teach me not to generate a test document. :-(  Let me see if I can come up with something similar.

Comment 5

10 years ago
Yes, I can't work on this until we have a new testcase.

Updated

10 years ago
Severity: normal → major
Whiteboard: orca:urgent
(Assignee)

Comment 6

10 years ago
Assigning to me.  I'll learn javascript. ;-)  Sorry for the delay.
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Assignee: aaronleventhal → joanmarie.diggs
Status: ASSIGNED → NEW

Comment 7

10 years ago
If it's too hard to find a new real example on the web, then perhaps this shouldn't be considered urgent anyway?

Comment 8

10 years ago
Please re-block fox3access and re-add "orca:urgent" if a new real-world test case becomes available.
No longer blocks: 396346
Whiteboard: orca:urgent
(Assignee)

Comment 9

10 years ago
Why don't we just close it and re-open should that occur?

I've been trying to reproduce it via javascript and haven't figured out the magic that caused events to be missing.
(Assignee)

Comment 10

10 years ago
Since no one has objected.... :-)

Closing as WORKSFORME since all attempts at producing a test case resulted in the correct events being generated.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.