[regression] context menu has all options showing, not all working

VERIFIED DUPLICATE of bug 39422

Status

SeaMonkey
UI Design
P3
major
VERIFIED DUPLICATE of bug 39422
18 years ago
14 years ago

People

(Reporter: Doron Rosenberg (IBM), Assigned: Bill Law)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Context menu has all options showing, and not all of em are working. seen in
win98 mozilla bits and linux commercial bits.  Build 2000051609.

Assiging to XPApps.
(Reporter)

Comment 1

18 years ago
adding appropiate keywords
Keywords: dogfood, nsbeta2, regression
Summary: [regression] context menu has all options showing, not all working → [regression] context menu has all options showing, not all working
Created attachment 8730 [details]
context menu [from comm build, winNT]
examples of context menu items not working (pls let us know if this relevent
here, or should be filed separately):

* over a link, select Open Link in New Window. result: nothing happens.
* over a link, select Edit Link in Composer. result: nothing happens.
* over an image, select View Image. result: nothing happens.
* all of the Save... items don't work (nothing happens, ie, no File Save
dialog).
* Copy Link and Copy Image Location don't work either.
bill/chris, is this yours?

Comment 5

18 years ago
I think this is bill's, let's start there.
Assignee: don → law
(Assignee)

Comment 6

18 years ago
In my debug build, I have no context menus at all.  I get an assertion in 
nsPopupFrame or some such.  It might be that in release builds the result is as 
described.  I'll look at the release build and see what I can see.  I'm thinking 
this is an xptoolkit thing; nothing has changed at our level (so far as I know).
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
I think this is a dup of 39422.  I'm building the fix for that one and once I 
see this is fixed, too, then I'll resolve this one as a DUP.
(Assignee)

Comment 8

18 years ago
This is fixed by applying the patch for bug 39422
(mozilla/layout/events/src/nsEventListenerManager.cpp).

*** This bug has been marked as a duplicate of 39422 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

18 years ago
*** Bug 39551 has been marked as a duplicate of this bug. ***
verif.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.