Firefox Microsummary componet does no provide a way to delete the generator

RESOLVED DUPLICATE of bug 341336

Status

Firefox Graveyard
Microsummaries
--
major
RESOLVED DUPLICATE of bug 341336
11 years ago
2 years ago

People

(Reporter: Bo Yang, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
Microsummary Service provide a way for extension developer to add/install a new microsummary generator to Firefox. But if the user want to delete some of edit some of installed generators, he have no way to do it. 
Microsummary generator XML files are stored in the Profiles\microsummary-generators directory. Of course, developers are always able to delete these XML files directly. But the problem is that although these files are deleted, there are some caches in memory of the installed microsummary. And this make the user confused about whether he has deleted the microsummary or not. 
So, I fill this bug. I think microsummary service should provide a way to delete the some generators. And I make a proposal:

bool removeGenerator(nsIMicrosummary ms);//Remove the generator for the give ms
nsISimpleEnumerator removeGeneratorsOfPage( nsIURI pageURI);
//Remove the generators for the give page
bool removeGeneratorOfBookmark( long bookmarkId);
//Remove the generator for microsummary of the given bookmark if any

That is all. Thanks!

Comment 1

11 years ago
Bug 341336 is about the GUI, but there should be an API too (see comment 4).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 341336
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.