Texts in bugzilla show_bug page are not rendered on OpenSolaris

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: ginnchen+exoracle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Most of texts and some widgets in bugzilla show_bug page are not rendered since 2007-8-28.
See attachment.
If I scroll the page with mouse, or move the pointer on the text, some texts will appear.

Tested on both SPARC and x86.
Nevada 70a and 71.

I've confirmed it's triggered by Bug 379886.
(Reporter)

Comment 1

11 years ago
Created attachment 278932 [details]
screenshot
(Reporter)

Comment 2

11 years ago
Some fonts are not rendered correctly in Firefox.
I still could not figure out why.

This problem can be reproduced without patch of Bug 379886.
e.g.
In Gnome Font Preferences, set Application font to Serif instead of Sans.
You will notice a lots of text in menu, toolbar, dialog are missing on Solaris Nevada.
But gnome apps are fine.

To workaround of this bug, you can choose some fonts that work with current Minefield.
Courier for monospace
Helvetica for sans-serif
Times for serif
(Reporter)

Comment 3

11 years ago
Firefox 2 doesn't have this issue.

So I guess maybe it's related to cairo rendering.

BTW: You may see the same problem with lxr.mozilla.org.

Comment 4

11 years ago
Linux had an identical-looking problem from 2007-08-02 to 2007-08-21ish, see bug 390787 and bug 327879 (an older, simliar bug that only showed on some systems)

I don't know if what went on in those bugs will be helpful, though, because they were confusing to me, but I hope it helps :)
(Reporter)

Comment 5

11 years ago
Yes, it helps.

I set a breakpoint at _cairo_error.

It seems FT_Load_Glyph returns 0, but glyph->bitmap.width and rows are 0, glyph->format is FT_GLYPH_FORMAT_BITMAP.

It is freetype2 9.8.3.
(Reporter)

Comment 6

11 years ago
I think the problem is bitmap fonts fail at some sizes.
I don't know why bug 390787 didn't fix Solaris.

A workaround is to copy /etc/fonts/conf.d/10-no-bitmaps.conf from a Linux machine to your Solaris $HOME/.fonts.conf
(maybe need to run fc-cache -f)
(Reporter)

Comment 7

11 years ago
The problem is gone if I remove /usr/openwin/lib/X11/fonts/pcf.

Don't know where is the real cause yet.

BTW: Add FT_LOAD_NO_BITMAP to FT_Load_Glyph doesn't help, because pcf fonts are always FT_GLYPH_FORMAT_BITMAP.
(Reporter)

Comment 8

11 years ago
FT_Load_Glyph failed when glyph_index is 1.
The same pcf file works if  glyph_index is not 1.
(Reporter)

Comment 9

11 years ago
hmm, glyph_index 1 should be whitespace.
(Reporter)

Comment 10

11 years ago
It is fixed by recent cairo upgrade.

gfx/cairo/cairo/src/cairo-ft-font.c

Looks like
 751 vladimir 1.30     if (width == 0 || height == 0) {
 752               	*surface = (cairo_image_surface_t *)
 753               	    cairo_image_surface_create_for_data (NULL, format, 0, 0, 0);
 754               	return (*surface)->base.status;
 755                   }
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.