Closed Bug 394369 Opened 13 years ago Closed 13 years ago

Error in FeedProcessor.js when adding Live Bookmark for http://events.ccc.de/feed/

Categories

(Firefox Graveyard :: RSS Discovery and Preview, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 381357

People

(Reporter: abillings, Unassigned)

References

()

Details

Attachments

(1 file)

Using the nightly trunk build, when I try to add a live bookmark for http://events.ccc.de/feed/, I see the following error twice in the error console:

Error: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISAXXMLReader.onDataAvailable]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: file:///Users/abillings/Desktop/Nightly.app/Contents/MacOS/components/FeedProcessor.js :: FP_onDataAvailable :: line 1320"  data: no]
Source File: file:///Users/abillings/Desktop/Nightly.app/Contents/MacOS/components/FeedProcessor.js
Line: 1320

The folder for the Live Bookmark will not have the Live Bookmark icon. The folder contents are one item that is named "Live Bookmark load..." with a Location of "about:livemark-loading".

On the 2.0.0.6 release build, the live bookmark is added and loads fine.

This was found in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007083004 Minefield/3.0a8pre.
same on XP. confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a8pre) Gecko/2007083005 Minefield/3.0a8pre ID:2007083005
OS: Mac OS X → All
Hardware: Macintosh → PC
Attached file The Feed in question
Adding the feed so we don't lose it in case it is something in the rotating contents...
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381357
How is this a dupe? I can add other feeds without problems (I checked). 

Besides, this bug has a repro case (the feed) attached where the comments in the other bug state that people can no longer repro with the feed there.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #4)
> How is this a dupe? I can add other feeds without problems (I checked).

I'm not sure I understand your point. Bug 381357 was reported about three feeds from a single server; its duplicates were all reported about single feeds. I'm unable to find anything in any of the bugs which said or even implied that the reporter was seeing the problem with every feed, and just happened to be mentioning this single example out of the totality of the feeds where he or she had seen it.
 
> Besides, this bug has a repro case (the feed) attached where the comments in
> the other bug state that people can no longer repro with the feed there.

Comments and people, the plurals, are inaccurate: one person made one comment saying he didn't see it, Ria said it still happens, and the rest of the cc list refrained from chiming in because she was right.

Attaching the feed is always a good idea, but since it's in bmo now, a comment in bug 381357 saying "attachment 279017 [details] also demonstrates the same thing, if the rest of the feeds here and in the dupes go away" would serve the same purpose as having this bug open because it has an attachment.

So, similarities:

This bug - adding a particular feed as a livemark throws NS_NOINTERFACE in nsISAXXMLReader.onDataAvailable.

That bug and its dupes - adding a particular feed as a livemark throws NS_NOINTERFACE in nsISAXXMLReader.onDataAvailable.

This bug - the problem feed is served as text/html

That bug and its dupes - the problem feeds are served as text/html and text/plain

This bug - serving a copy of the feed with a more reasonable content-type makes the problem go away

That bug and its dupes - serving a copy of the feeds with a more reasonable content-type makes the problem go away

Differences:

That bug (and its dupes, for that matter) was reported earlier than this bug

That bug is marked blocking-firefox3+

That bug has an owner

That bug has a useful cc list of RSS and Places developers

This bug...
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381357
Verified as a dupe.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.