hangs when web page uses flash plugin

VERIFIED DUPLICATE of bug 37463

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 37463
18 years ago
18 years ago

People

(Reporter: Mohan Rao, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)
BuildID:    2000042708

The above page needs to use the flash plugin. When you go to the page the flash 
animation is displayed correctly but when you click on any link on the page the 
browser hangs. This did not happen with M15 and before !!

Reproducible: Always
Steps to Reproduce:
1.Copy the flash plugin dll - npswf32.dll to the plugins directory under 
mozilla/dist/win32_o.obj/bin/plugings
2.Point your browser to the above location - www.cyberworldcorp.com-or any 
other page that uses flash
3. Click on the icon or any other link on the page

Actual Results:  Browser freezes- When I start the Task Manager it says that 
Mozilla is not responding

Expected Results:  The browser should open the link in the window

I first observed this when I embedded Gecko in my application. All callbacks 
are received fine infact I even get OnDownloadComplete but it hangs after that. 
When I do a debug break the Visual C++ debugger tells me that there is a 
potential deadlock and it was soft broken.

Comment 1

18 years ago
Confirmed on build 2000051520 on NT4.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
updating component and owner.
Assignee: asadotzler → av
Component: Browser-General → Plug-ins
QA Contact: jelwell → shrir

Comment 3

18 years ago
This bug is not related to flash plugin. The plugin plays fine even when 
isolated from the page. This is a javascript issue where left clicking on link 
is freezing the browser. Note that right clicking is working fine on that url.  
 Reassigning bug to DOM 0. 
Assignee: av → jst
Severity: blocker → normal
Component: Plug-ins → DOM Level 0
QA Contact: shrir → desale

Comment 4

18 years ago
Sounds like bug 37463: lockup/freeze upon javascript:window.location="...";
Marking dup. Please reopen or comment if you disagree. CC'ing self.

*** This bug has been marked as a duplicate of 37463 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Bug 37463 is fixed. Clicking links on www.cyberworldcorp.com works fine now
(PC/Linux, build 2000063020).

Comment 6

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.