Software Error occurs on selecting "My Plans" option

RESOLVED DUPLICATE of bug 388842

Status

Testopia
Test Plans
--
major
RESOLVED DUPLICATE of bug 388842
10 years ago
10 years ago

People

(Reporter: usman, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 2.0.50727)
Build Identifier: Testopia 1.3 beta

Installed bugzilla 3.0 and Testopia 1.3,Sucessfull installation

In Local host after login if i select "My Plans" the the following error occurs
Software error:
DBD::mysql::db selectcol_arrayref failed: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation ' IN ' [for Statement "SELECT test_plans.plan_id FROM test_plans  INNER JOIN test_plan_permissions ON (test_plans.plan_id = test_plan_permissions.plan_id) INNER JOIN profiles AS map_author ON (test_plans.author_id = map_author.userid) WHERE test_plan_permissions.permissions > 0 AND test_plan_permissions.userid = 71 AND test_plans.isactive = 1 AND ((map_author.login_name IN ('usman.basha@niit-tech.com'))) GROUP BY test_plans.plan_id"] at Bugzilla/Testopia/Table.pm line 121
	Bugzilla::Testopia::Table::init('Bugzilla::Testopia::Table=HASH(0x2c423dc)', 'plan', 'tr_list_plans.cgi', 'Bugzilla::CGI=HASH(0x2a361ac)', 'undef', 'SELECT test_plans.plan_id FROM test_plans  INNER JOIN test_pl...') called at Bugzilla/Testopia/Table.pm line 88
	Bugzilla::Testopia::Table::new('Bugzilla::Testopia::Table', 'plan', 'tr_list_plans.cgi', 'Bugzilla::CGI=HASH(0x2a361ac)', 'undef', 'SELECT test_plans.plan_id FROM test_plans  INNER JOIN test_pl...') called at C:/bugzilla/tr_list_plans.cgi line 151

For help, please send mail to the webmaster (admin@blrrkt.in.niit.com), giving this error message and the time and date of the error. 


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Even "New Plan" and "Environment" links are not appearing when i login.

Comment 2

10 years ago
Please show the complete output of checksetup.pl
(Reporter)

Comment 3

10 years ago
C:\bugzilla>checksetup.pl

* This is Bugzilla 3.0 on perl 5.8.6
* Running on Win2000 Build 2195 (Service Pack 4)

Checking perl modules...
Checking for             CGI (v2.93)   ok: found v3.05
Checking for        TimeDate (v2.21)   ok: found v2.22
Checking for             DBI (v1.41)   ok: found v1.57
Checking for       PathTools (v0.84)   ok: found v3.01
Checking for Template-Toolkit (v2.12)   ok: found v2.15
Checking for      Email-Send (v2.16)   ok: found v2.185
Checking for Email-MIME-Modifier (any)     ok: found v1.442
Checking for            JSON (v1.07)   ok: found v1.14
Checking for       Text-Diff (v0.35)   ok: found v0.35

Checking available perl DBD modules...
Checking for          DBD-Pg (v1.45)    not found
Checking for       DBD-mysql (v2.9003) ok: found v3.0002

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.16
Checking for     Template-GD (any)     ok: found v1.56
Checking for           Chart (v1.0)    ok: found v2.3
Checking for         GDGraph (any)     ok: found v1.43
Checking for      GDTextUtil (any)     ok: found v0.86
Checking for        XML-Twig (any)     ok: found v3.26
Checking for      MIME-tools (v5.406)  ok: found v5.411
Checking for     libwww-perl (any)     ok: found v2.033
Checking for     PatchReader (v0.9.4)  ok: found v0.9.5
Checking for      PerlMagick (any)      not found
Checking for       perl-ldap (any)     ok: found v0.34
Checking for       SOAP-Lite (any)     ok: found v0.55
Checking for     HTML-Parser (v3.40)    found v3.38
Checking for   HTML-Scrubber (any)     ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any)     ok: found v1.3
Checking for     Email-Reply (any)     ok: found v1.202
Checking for        mod_perl (v1.999022) ok: found v2.000003
Checking for             CGI (v3.11)    found v3.05
Checking for      Apache-DBI (v0.96)   ok: found v1.06

* NOTE: You must run any commands listed below as Administrator.

***********************************************************************
* Note For Windows Users                                              *
***********************************************************************
* In order to install the modules listed below, you first have to run *
* the following command as an Administrator:                          *
*                                                                     *
*   ppm repo add theory58S http://theoryx5.uwinnipeg.ca/ppms          *
*                                                                     *
* Then you have to do (also as an Administrator):                     *
*                                                                     *
*   ppm repo up theory58S                                             *
*                                                                     *
* Do that last command over and over until you see "theory58S" at the *
* top of the displayed list.                                          *
***********************************************************************
**********************************************************************
* OPTIONAL MODULES                                                   *
**********************************************************************
* Certain Perl modules are not required by Bugzilla, but by          *
* installing the latest version you gain access to additional        *
* features.                                                          *
*                                                                    *
* The optional modules you do not have installed are listed below,   *
* with the name of the feature they enable. If you want to install   *
* one of these modules, just run the appropriate command in the      *
* "COMMANDS TO INSTALL" section.                                     *
**********************************************************************

***********************************************************************
* MODULE NAME * ENABLES FEATURE(S)                                    *
***********************************************************************
* HTML-Parser * More HTML in Product/Group Descriptions               *
*  PerlMagick * Optionally Convert BMP Attachments to PNGs            *
*         CGI * mod_perl                                              *
***********************************************************************
COMMANDS TO INSTALL:

    HTML-Parser: ppm install HTML-Parser
     PerlMagick: ppm install PerlMagick
            CGI: ppm install CGI
Reading ./localconfig...

OPTIONAL NOTE: If you want to be able to use the 'difference between two
patches' feature of Bugzilla (which requires the PatchReader Perl module
as well), you should install patchutils from:

    http://cyberelk.net/tim/patchutils/

Checking for       DBD-mysql (v2.9003) ok: found v3.0002
Checking for           MySQL (v4.1.2)  ok: found v4.1.8-nt

Removing existing compiled templates ...
Precompiling templates...

Checking Testopia setup ...
Attempt to free unreferenced scalar: SV 0x450c5b0, Perl interpreter: 0x15d43ec a
t Bugzilla/DB/Mysql.pm line 310.
Populating test plan ACLs ...
Free to wrong pool 15d27f8 not ff at Bugzilla/Hook.pm line 46.

C:\bugzilla>


Can you guide me how to do patching mannually.

(Reporter)

Comment 4

10 years ago
(In reply to comment #2)
> Please show the complete output of checksetup.pl

C:\bugzilla>checksetup.pl

* This is Bugzilla 3.0 on perl 5.8.6
* Running on Win2000 Build 2195 (Service Pack 4)

Checking perl modules...
Checking for             CGI (v2.93)   ok: found v3.05
Checking for        TimeDate (v2.21)   ok: found v2.22
Checking for             DBI (v1.41)   ok: found v1.57
Checking for       PathTools (v0.84)   ok: found v3.01
Checking for Template-Toolkit (v2.12)   ok: found v2.15
Checking for      Email-Send (v2.16)   ok: found v2.185
Checking for Email-MIME-Modifier (any)     ok: found v1.442
Checking for            JSON (v1.07)   ok: found v1.14
Checking for       Text-Diff (v0.35)   ok: found v0.35

Checking available perl DBD modules...
Checking for          DBD-Pg (v1.45)    not found
Checking for       DBD-mysql (v2.9003) ok: found v3.0002

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.16
Checking for     Template-GD (any)     ok: found v1.56
Checking for           Chart (v1.0)    ok: found v2.3
Checking for         GDGraph (any)     ok: found v1.43
Checking for      GDTextUtil (any)     ok: found v0.86
Checking for        XML-Twig (any)     ok: found v3.26
Checking for      MIME-tools (v5.406)  ok: found v5.411
Checking for     libwww-perl (any)     ok: found v2.033
Checking for     PatchReader (v0.9.4)  ok: found v0.9.5
Checking for      PerlMagick (any)      not found
Checking for       perl-ldap (any)     ok: found v0.34
Checking for       SOAP-Lite (any)     ok: found v0.55
Checking for     HTML-Parser (v3.40)    found v3.38
Checking for   HTML-Scrubber (any)     ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any)     ok: found v1.3
Checking for     Email-Reply (any)     ok: found v1.202
Checking for        mod_perl (v1.999022) ok: found v2.000003
Checking for             CGI (v3.11)    found v3.05
Checking for      Apache-DBI (v0.96)   ok: found v1.06

* NOTE: You must run any commands listed below as Administrator.

***********************************************************************
* Note For Windows Users                                              *
***********************************************************************
* In order to install the modules listed below, you first have to run *
* the following command as an Administrator:                          *
*                                                                     *
*   ppm repo add theory58S http://theoryx5.uwinnipeg.ca/ppms          *
*                                                                     *
* Then you have to do (also as an Administrator):                     *
*                                                                     *
*   ppm repo up theory58S                                             *
*                                                                     *
* Do that last command over and over until you see "theory58S" at the *
* top of the displayed list.                                          *
***********************************************************************
**********************************************************************
* OPTIONAL MODULES                                                   *
**********************************************************************
* Certain Perl modules are not required by Bugzilla, but by          *
* installing the latest version you gain access to additional        *
* features.                                                          *
*                                                                    *
* The optional modules you do not have installed are listed below,   *
* with the name of the feature they enable. If you want to install   *
* one of these modules, just run the appropriate command in the      *
* "COMMANDS TO INSTALL" section.                                     *
**********************************************************************

***********************************************************************
* MODULE NAME * ENABLES FEATURE(S)                                    *
***********************************************************************
* HTML-Parser * More HTML in Product/Group Descriptions               *
*  PerlMagick * Optionally Convert BMP Attachments to PNGs            *
*         CGI * mod_perl                                              *
***********************************************************************
COMMANDS TO INSTALL:

    HTML-Parser: ppm install HTML-Parser
     PerlMagick: ppm install PerlMagick
            CGI: ppm install CGI
Reading ./localconfig...

OPTIONAL NOTE: If you want to be able to use the 'difference between two
patches' feature of Bugzilla (which requires the PatchReader Perl module
as well), you should install patchutils from:

    http://cyberelk.net/tim/patchutils/

Checking for       DBD-mysql (v2.9003) ok: found v3.0002
Checking for           MySQL (v4.1.2)  ok: found v4.1.8-nt

Removing existing compiled templates ...
Precompiling templates...

Checking Testopia setup ...
Attempt to free unreferenced scalar: SV 0x450c5b0, Perl interpreter: 0x15d43ec
a
t Bugzilla/DB/Mysql.pm line 310.
Populating test plan ACLs ...
Free to wrong pool 15d27f8 not ff at Bugzilla/Hook.pm line 46.

C:\bugzilla>


Can you guide me how to do patching mannually.

Comment 5

10 years ago
The problem is here:

Attempt to free unreferenced scalar: SV 0x450c5b0, Perl interpreter: 0x15d43ec
at Bugzilla/DB/Mysql.pm line 310.
Populating test plan ACLs ...
Free to wrong pool 15d27f8 not ff at Bugzilla/Hook.pm line 46.

This is a bug in perl.exe -- nothing we can do to fix it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 6

10 years ago
See these bug reports against ActivePerl:

http://bugs.activestate.com/show_bug.cgi?id=57328
http://bugs.activestate.com/show_bug.cgi?id=70858

Updated

10 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 388842
You need to log in before you can comment on or make changes to this bug.