Make use of type="number" for textboxes representing integer preferences

RESOLVED FIXED in Firefox 3 beta1

Status

()

Firefox
Preferences
--
enhancement
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 3 beta1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 279077 [details] [diff] [review]
patch
Attachment #279077 - Flags: review?(mano)

Comment 1

11 years ago
There's already been two other bugs about this.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 245421
(Assignee)

Comment 2

11 years ago
Based on the summary and the patch, this isn't a duplicate of bug 245421; the bugs overlap at most. What is the other bug?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

11 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

11 years ago
Blocks: 245421

Comment 3

11 years ago
Just one bug for all this please. I don't remember what the other bug is, but it also had a patch
(Assignee)

Comment 4

11 years ago
(In reply to comment #3)
> Just one bug for all this please.

Umm, why? If your patch gets checked in first, I can update mine, and vice versa. They are neither identical nor exclusive. Also, bug 245421 is a back-end bug to start with (which could be left open even if your patch gets in) whereas this one is actually an enhancement request.
The other bug Neil is thinking of is bug 377973.
(Assignee)

Comment 6

11 years ago
Nice.
So, can we just land this patch as a starter?
Then Ryan can do his CSS tweaking (I second bug 245421 comment 4; it doesn't belong there) and Neil can add max values as a band-aid for bug 245421.
That sounds like a fine plan to me. The only thing I was concerned about with the patch in bug 245421 was how it would deal with preferences that have values greater than the maxlength being added.
Although this bug and bug 377973 really are duplicates - the patch there has ui+r, but I think I prefer this one (at least as a first step).
Duplicate of this bug: 377973
Bug 378157 is the styling issue.
(Assignee)

Updated

11 years ago
Depends on: 378157
(Assignee)

Updated

11 years ago
Attachment #279077 - Flags: approval1.9?

Updated

11 years ago
Depends on: 365893

Updated

11 years ago
Attachment #279077 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Checking in browser/components/preferences/advanced.xul;
/cvsroot/mozilla/browser/components/preferences/advanced.xul,v  <--  advanced.xul
new revision: 1.38; previous revision: 1.37
done
Checking in browser/components/preferences/connection.xul;
/cvsroot/mozilla/browser/components/preferences/connection.xul,v  <--  connection.xul
new revision: 1.11; previous revision: 1.10
done
Checking in browser/components/preferences/privacy.xul;
/cvsroot/mozilla/browser/components/preferences/privacy.xul,v  <--  privacy.xul
new revision: 1.21; previous revision: 1.20
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M9
You need to log in before you can comment on or make changes to this bug.