Recurring event failure

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Joseph Martos, Unassigned)

Tracking

Sunbird 0.3a1
x86
Windows XP

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla Sunbird, downloaded in 2006

When I try to schedule an all-day event on the last Tuesday of every month, if I do this in a month that has a 5th Tuesday, the event appears only in those months that have 5 Tuesdays. I do not know if this happens when trying to schedule recurring events on other days of the week.

Reproducible: Always

Steps to Reproduce:
1.Schedule an event for Tuesday October 30.
2.Set Recurrence for Last Tuesday of the month.
3.The next recurrence listed is January 29, with none in November or December.
Actual Results:  
See Step 3, above.

Expected Results:  
The event should recur on every last Tuesday of the month.

Comment 1

10 years ago
This works for me without problems using both Sunbird 0.5 (20070614) and Sunbird 0.3 (20061006) on Windows 2000.

Please note the exact Sunbird version from menu Help -> About Sunbird.

Please check that you selected "Last Tuesday of the month" instead of "Fifth Tuesday of the month" in the Edit Recurrence dialog.
(Reporter)

Comment 2

10 years ago
Following your advice, I found that I am using version 0.3a1.

The two choices I saw were "On the 30th of the month" and "Last Tuesday of the month." I selected the latter.

Comment 3

10 years ago
Wow, this release is really, really antique. Sunbird 0.3 Alpha 1 was released back in 2005. More than 1200 bugs were fixed since Sunbird 0.3 Alpha 1 by now. I recommend to upgrade to the current release Sunbird 0.5 and test again.
Version: unspecified → Sunbird 0.3a1
(Reporter)

Comment 4

10 years ago
Thanks. Did that.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.