Drag & drop of text within editor (midas) does nothing

RESOLVED WORKSFORME

Status

()

Core
Editor
P4
normal
RESOLVED WORKSFORME
11 years ago
2 years ago

People

(Reporter: Georg Maaß, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dbaron-1.9:RuCc])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4
Build Identifier: XulRUnner Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.9a8pre) Gecko/2007083108

Trying to drag text in MIDAS from one location in the editor window to an other does nothing. On windows you get a cursor indicating this as impossible, on Mac the cursor remains the insert cursor but when dropping the text is allways dropped to its original position. In earlier builds (months ago) this worked.

Reproducible: Always

Updated

11 years ago
Flags: blocking1.9?
Keywords: regression
Summary: Drag & Drop does nothing → Drag & drop of text within editor (midas) does nothing
Flags: blocking1.9? → blocking1.9+
When did this regress?  Was it when bug 237964 landed?  If so, could you mark it as blocking bug 237964?
Whiteboard: [dbaron-1.9:RuCc]
(Reporter)

Comment 2

10 years ago
I'm not sure, when the regression begun. I detected it with the nightly from 31 August, which is near to the beginning of the activities of bug 237964; so I set the blocking.

In Nightly from it is still: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a9pre) Gecko/2007100208

I should download a new nightly and test that too.
Blocks: 237964
(Reporter)

Comment 3

10 years ago
With newest nightly Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.9a9pre) Gecko/2007102008 it is still the same.
Is this another only-in-XULRunner bug (e.g., like bug 391429)?  

I get a cursor and have no issues drag-dropping on http://www.mozilla.org/editor/midasdemo/ in my Camino trunk build and today's Fx trunk nighty.
(Reporter)

Comment 5

10 years ago
I 've tested it in XulRunner only, but I also might test at home using minefield instead of Xulrunner to launch the XUL application to see, whether it occurs there too.
(Reporter)

Comment 6

10 years ago
Same result, when using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.9a8pre) Gecko/2007090104 Minefield/3.0a8pre instead of XulRunner.
(Reporter)

Comment 7

10 years ago
Also the same with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.9a9pre) Gecko/2007102804 Minefield/3.0a9pre
I don't see this on [Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102510 Minefield/3.0a9pre], so I'm changing the OS field to Mac.
OS: All → Mac OS X
(Reporter)

Comment 9

10 years ago
In XULRUnner Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9a9pre) Gecko/2007110108 the problem seems to be partially fixed. I must ask my coworker when he is back from vacation what's the exact difference between the two situations of our XUL application. This might help to create a simple test case.
I don't see this in [Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9a9pre) Gecko/2007110404 Minefield/3.0a9pre] either. Xulrunner only?
(Reporter)

Comment 11

10 years ago
Same as on Mac also on Windows with XulRunner: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110410 so changing OS field from Mac to All, because it is at least on Mac and Win; not tested anywhere else.
OS: Mac OS X → All

Comment 12

10 years ago
Moving to the wanted list - re-nom if you disagree..
Flags: wanted1.9+
Flags: blocking1.9-
Flags: blocking1.9+
I can't reproduce on Mac or Windows either.
Flags: wanted1.9+ → wanted1.9-
Hi,

I wasn't able to reproduce this issue on the latest Firefox release (45.0.1, Build ID 20160315153207) or the latest Nightly (48.0a1, Build ID 20160403030243) using the MIDAS demo (http://www.mozilla.org/editor/midasdemo/). Could you please retest this issue on the latest Firefox release and Nightly and provide your results? When doing this please use a clean, new profile.

Thanks,
Cipri
Flags: needinfo?(georg)
Since the reporter didn't provide the required information and the fact that I could not reproduce the issue, I will mark it as Resolved-Worksforme. If anyone still encounters the issue, feel free to reopen this one or open a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(georg)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.