Allow extension added menu items to remain when all browser windows are closed

RESOLVED WONTFIX

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED WONTFIX
11 years ago
a year ago

People

(Reporter: morac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

My extension, Session Manager adds a submenu to the Tools menu.  I've been getting bug reports that this menu goes away when there are no browser windows open.  At first I was confused by this since I don't have a Mac, but I've since learned that the Mac toolbar remains even when there are no windows open.

From my understanding, when all windows are closed, any menu entries by extensions are automatically removed.  It would be nice if there was some kind of method to allow menu entries to remain after the windows are closed.

For example in Session Manager's case, to load a session a Mac user must first open a blank window in order to access the sub menu in the toolbar menu.  Then the user can open a session.  It would be nice if the user could just open the session without having to open a blank window first.

Reproducible: Always
Hi Michael,
as this has been reported against FF 2 and inner parts of the browser (and I guess the add-on) have changed, is this still true, or can this bug be closed?
(Reporter)

Comment 2

a year ago
I have no idea if it's still occurring or not as I still don't have a Mac.  I haven't gotten any complaints about it for a long time though.
Thanks for quickly replying Michael. I will close it as wontfix for now. Please feel free to reopen if necessary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.