Downloads not listed for "Save As Web Page, Complete" when page has been modified by dom inspector

VERIFIED WORKSFORME

Status

()

Toolkit
Downloads API
VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({qawanted, regression})

Trunk
x86
Windows XP
qawanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
This might be basically the same issue as bug 393895, not sure.

To reproduce:
- Open http://www.google.nl/firefox
- Open dom inspector
- Delete everything inside the <body>
- Then do a "Save As Web Page, Complete"

Expected result:
- Page is saved, download is listed in download manager

Actual result:
- Page is saved, download is not listed in download manager

Also, I see this error in the error console appearing:
Error: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://global/content/contentAreaUtils.js :: internalSave :: line 318"  data: no]
Source File: chrome://global/content/contentAreaUtils.js
Line: 318
Martijn, is this fixed now that Bug 393895 is fixed?
Keywords: qawanted
(Reporter)

Comment 2

11 years ago
Yeah, this is worksforme, using current trunk build.
I'm marking this worksforme, but it might as well be a duplicate of bug 393895.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
verified per martijn's comments
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.