Overflow scrollbar is not fully functional despite mousethrough="always"

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
RESOLVED WORKSFORME
11 years ago
2 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

642 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

11 years ago
Created attachment 279486 [details]
Testcase

I have a stack with two elements. The element below has overflow, a scrollbar appears. Because of the mousethrough="always" it still receives mouse events, you can press the buttons or move the thumb of the scrollbar. However, clicking anywhere else in the scrollbar (usually scrolls by one page up or down) doesn't have any effect. Putting the element with overflow to the top makes the scrollbar work again.

I see this only on trunk, Firefox 2.0.0.6 is fine.
The Test Case provided is obsolete. Please provide another test case if this issue is still relevant. If it is not, please close this issue.
Flags: needinfo?(trev.moz)
(Reporter)

Comment 2

2 years ago
I don't think TomTom still needs this fixed after eight years...
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(trev.moz)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.