Closed Bug 394795 Opened 12 years ago Closed 2 years ago

Font and color preference windows are cropped from the right on some on some environments

Categories

(Firefox :: Preferences, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: ht990332, Unassigned)

References

Details

Attachments

(6 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007090318 Firefox/3.0a8pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007090318 Firefox/3.0a8pre

Preferences > Content > 'Fonts & Colors' > Colors 
is cropped from the right (width)

Preferences > Content > 'Fonts & Colors' > Advanced/Fonts
is also cropped from the right (width)

I'll attach two screenshots


Reproducible: Always
Attached image Cropped colors options
Attached image Cropped Fonts options
I have the same problem (Cropped from the right) with Preferences > Content > Fonts & Colors > Colors  but not with Fonts & Colors > Advanced. See two attachments.


Reproducible: Always
Attached image Colors Croppage
This seems similar to https://bugzilla.mozilla.org/show_bug.cgi?id=393750 but the other bug looks more like a language issue.
Attached image Cropped advanced window
Bug is still in latest builds.
This is a pretty obvious bug. Anyone can confirm?

I think auto 'resizing to content' is only implemented in vertical direction (length) and not horizontally (width).
Both the Fonts and Colors page are not cropped for me, on Ubuntu hardy with near default font settings. The width of these dialogs are respectively set to 41em and 38em. According to your system font configuration, these widths could be too narrow for the window.

This is a testcase to see if the text will fit in the given width (font family and size should be the one used by XUL):

data:text/html,<div style="font-family: Sans; font-size: 13.333px;"><div style="width:38em; border: thin solid red;">Allow pages to choose their own colors, instead of my selections above</div><div style="width:41em; border: thin solid red;">Allow pages to choose their own fonts, instead of my selections above</div></div>

I'm not sure what's the best option here. Raising the width would prevent the cropping for some, but would be too wide for others.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Attached file testcase
Should be better in an attachment.
Summary: Some options in preferences are cropped from the right → Font and color preference windows are cropped from the right on some on some environments
Duplicate of this bug: 417336
Duplicate of this bug: 425905
Duplicate of this bug: 549313
This is obsolete by now. it doesn't happen in the in-page dialogs.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.