SAVE AS...NOT ADDING CORRECT FILENAME .EXTENSIONS

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: ck212w, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-06-30], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Originally occured with .MAFF functions, Firefox refused to save any file with a .maf and a .mhtml in the save as dialog window. On further investigation, 'save as' did not correctly link file with file folder contents for save as "web page complete". I had trouble isolating what actual extension was used when trying to save as complete web page, but I think it just doesn't give it one. Upon adding the .htm/.html extension to the filename, it was correctly linked by windows with its 'extra folder' (don't know how to describe it), but I do not know how many times I have erronoeusly saved complete web pages that wound up with no extentions. Also noted, about mozilla archive, fic was achieved by deleting 'extensions.ini' 'extensions.cache' and 'extensions.rdf' while Firefox was offline. Thank you for investigated this issue.

Reproducible: Always

Steps to Reproduce:
1.go to any url
2.click save page as
3.select "Web Page, complete" in 'save as type' menu box
Actual Results:  
folder called FILENAME_files was created and a file named FILENAME

Expected Results:  
folder called FILENAME_files to be created and a file named FILENAME.html
(Reporter)

Updated

11 years ago

Comment 1

11 years ago
Works for me with the url that you gave, <http://www.psc-cavers.org/>. I see a Potomac Speleological Club.htm and a Potomac Speleological Club_files.
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-06-30]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.