MSVCR71.dll and MSVCP71.dll are not installed on Windows 2000 by default, preventing Eudora 8.0b1 to run

RESOLVED FIXED

Status

Penelope
Installer
P5
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Åke Bertenstam, Assigned: Jeff Beckley)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Eudora 8.0.0b1

When trying to start Eudora after installation all I get is an error box telling that the file mentioned in the summary can't be found in any of the folders connected with Eudora.
I seem to remember that same problem occured when I upgraded Eudora from 6.1.x to 7.0.9 and then it due to lack of administrative rights from my side. There is however no warning in the Readme file that such privileges are needed to install the program nor do I get such a warning from the installer (which I got when installing Eudora 7.0.9)

Reproducible: Always

Steps to Reproduce:
1. 
2.
3.



Would be grateful to get feedback if this error is just due to lack of administrative rights when trying install Eudora or if it is a real bug. If the former then perhaps a note should be added to the Readme file.

Comment 1

11 years ago
I had the same problem.  (Running in a standard user account) I ran the setup package under Vista.  Vista then requested my administrator password, which I provided.  This is a fairly fresh install of Vista with very little other software installed (only Eudora 7.0, OpenOffice, WordPerfect, Visual Studio 6.0, Firefox).  When I tried to run Eudora 8, I got the error message about MSVCR71.dll being missing.  I downloaded a copy and copied it into the Eudora folder.  I then tried again and got an error message about MSVCP71.dll being missing.  I downloaded that too and copied it to the Eudora folder.  Since then, Eudora 8 has being running OK.
(Reporter)

Comment 2

11 years ago
I have solved the problem in much the same way as you, i.e. by copying the missing rwo files from my Eudora 7.0 installation (in which Eudora is installed under /Documents and Settings and not in the Program folder). It now seems to work OK for me too.
It's interesting to note, however that I unlike you didn't got a message asking me to log in as administrator from the installer; when I tried to install Eudora 7.0 several months ago I got an error message from the installer that the program would not be properly installed if not logged in as administrator.
On my PC at work I don't have administrator privileges, I have not tested to install Eudora 8 on my laptop at home (which also has Windows 2000 as OS)

Comment 3

11 years ago
I think probably the message asking for the administrator password is specific to Vista.  I think the message was presented by the operating system rather than the installer. 

Updated

11 years ago
Assignee: mozilla-bugs → beckley
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
I'm updating the bug summary to better reflect what the problem is: both DLLs are not installed on Windows 2000 by default. From what I heard, you need Windows XP or newer. So the installer should provide them itself.
Severity: normal → major
Summary: File not installed properly (MSVCR71.dll) → MSVCR71.dll and MSVCP71.dll are not installed on Windows 2000 by default, preventing Eudora 8.0b1 to run
(Assignee)

Comment 5

11 years ago
In addition to grabbing those two DLLs from a Windows installation that has them, you can download them from one of the many DLL web sites: <http://www.google.com/search?q=download+DLL+files>.
Severity: major → normal

Comment 6

11 years ago
(In reply to comment #1)
 
>This is a fairly fresh install of Vista with very little other
> software installed (only Eudora 7.0,

Did the install of Eudora 8.0 overwrite your copy o Eudora 7.0 or make a second copy of Eudora for you?

jack

Comment 7

11 years ago
(In reply to comment #6)
> (In reply to comment #1)
> 
> Did the install of Eudora 8.0 overwrite your copy o Eudora 7.0 or make a second
> copy of Eudora for you?

I installed it as a second copy.  This was intentional on my part but I think it was also the default behaviour.  8.0 is in C:\Program Files\Eudora8, whilst 7 is in C:\Program Files\Qualcomm\Eudora.

Updated

10 years ago
Priority: -- → P5

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

10 years ago
This was fixed in Eudora 8.0.0b2.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.