Gray text in places search box gets confused by focus changes from menus

RESOLVED DUPLICATE of bug 389033

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 389033
10 years ago
8 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
(If anyone can write a better summary, please do.)

STR:
0. Open Firefox
1. Open the Bookmarks Organizer
2. Click a folder ("Quick Searches", for example) in the left-hand pane.
3. Open the edit menu, click "Find in 'Quick Searches'...".

Notice that the search box is now focused, and has no more text, and a cursor.

4. Hit the escape key.

Expected results:
Either of:
* the search box unfocuses, the text "Search in 'Quick Searches'" appears, no cursor in search box, the text in the search box is gray.
or:
* the search box remains focused, no text appears, the cursor stays in the search box, any text you type is black.

Actual results:
The search box seems to remain focused (or lose focus and then regain focus), the text "Search in 'Quick Searches'" reappears, the cursor stays in the search box, the text in the search box is black.
this sounds like a dup of bug #394889
(In reply to comment #1)
> this sounds like a dup of bug #394889

Which bug did you really mean? :)
> Which bug did you really mean? :)

oops, I meant bug #389033
(Reporter)

Comment 4

10 years ago
sspitzer's right, duping. Sorry. :-)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389033
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.