If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Uninitialized memory read in CERT_DecodeDERCertificate()

RESOLVED FIXED in 3.1

Status

NSS
Libraries
P3
normal
RESOLVED FIXED
18 years ago
17 years ago

People

(Reporter: Fred Roeber, Assigned: Nelson Bolyard (seldom reads bugmail))

Tracking

x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is a replacement for Netscape bug
http://scopus/bugsplat/show_bug.cgi?id=113763

In HCL_1_51
[W] UMR: Uninitialized memory read in CERT_DecodeDERCertificate {1 occurrence}
    Reading 4 bytes from 0x0004fafc (4 bytes at 0x0004fafc uninitialized)
    Address 0x0004fafc points into a fiber's stack 
    Address 0x0004fafc is 28 bytes past the start of local variable 'entry' in 
certcallback
    Thread ID: 0xb8
    Error location
        CERT_DecodeDERCertificate [certdb.c:518]
        certcallback   [pcertdb.c:4356]
        SEC_TraverseDBEntries [pcertdb.c:4306]
        SEC_TraversePermCerts [pcertdb.c:4393]
        pk11_importKeyDB [pkcs11.c:3274]
        NSC_FindObjectsInit [pkcs11.c:3557]
        pk11_FindObjectByTemplate [pk11cert.c:100]
        PK11_MatchItem [pk11cert.c:160]
        PK11_FindPrivateKeyFromCert [pk11cert.c:1169]
        prot_ssl_init  [prot_ssl.c:217]
                        nickname);
                    goto done;
                    }
             =>     psk = PK11_FindPrivateKeyFromCert(ppk11si, pcc, NULL);
                    if (psk == NULL) {
                    nslog(NULL, NSLOG_ERR, "Could not find private key\n");
                    goto done;
        imap_main      [imapd.c:421]


------- Additional Comments From nelsonb  07/01/98 16:47 ------- 

Changed product version to 1.5

Comment 1

17 years ago
Nelson, could you take a look at this Purify UMR error? Thanks.
Assignee: lord → nelsonb
Target Milestone: --- → 3.1
Version: unspecified → 3.0
(Assignee)

Comment 2

17 years ago
Javi fixed this bug back in September 1999, 
long before Fred moved this bug from bugsplat to bugzilla.  See
http://lxr.mozilla.org/mozilla/source/security/nss/lib/certdb/pcertdb.c#4528
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

17 years ago
*** Bug 39493 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.