Error properties files need to be included in ldapjdk.jar

RESOLVED FIXED

Status

Directory
LDAP Java SDK
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: nkinder, Assigned: mcs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070718 Fedora/1.5.0.12-4.fc6 Firefox/1.5.0.12
Build Identifier: 

There seems to be an error in the Ant build.xml file that results in the errors properties files not being included in the ldapjdk.jar file.  The jarfile task itself explicitly tries to include these properties files, but the problem is that they don't exist in the dist area, which is where the jarfile is created from.

The fix is to copy the properties files into the dist area from the source area.  The files will then be found during the jarfile creation.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 279650 [details] [diff] [review]
CVS Diffs

Comment 2

10 years ago
Ok.
(Reporter)

Comment 3

10 years ago
Thanks for the review Rich.  This is checked into HEAD now.

Checking in build.xml;
/cvsroot/mozilla/directory/java-sdk/build.xml,v  <--  build.xml
new revision: 1.5; previous revision: 1.4
done
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.