Icons for attachments do not match system default handlers

RESOLVED DUPLICATE of bug 255338

Status

RESOLVED DUPLICATE of bug 255338
11 years ago
10 years ago

People

(Reporter: nixon049, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: version 2.0.0.6 (20070728)

Messages with attached files on Thunderbird OSX do not match system icons for files with the identified MIME type. Most common example is MS Office documents, which show a ResEdit "Jack-in-the-box" icon even though ResEdit is NOT installed on this machine and is NOT the default handler. PDF icons are a blank file. Attachments should use the default icon specified by the system, as they do once saved to desktop.

Reproducible: Always

Steps to Reproduce:
1.Open mail with an attached file
2.Check icon displayed by Thunderbird in attachment pane
3.Save file to Desktop and compare icon shown there to the one shown in Thunderbird
Actual Results:  
Incorrect "Jack-in-the-box" icon or blank icon showed by Thunderbird; on Desktop file displays the normal attachment

Expected Results:  
Thunderbird should query system to display the correct icon, or at very least should have some inbuilt default icons for common file types that are more appropriate than the "Jack-in-the-box" ResEdit icon most commonly displayed

No matching bugs found using ResEdit, jack in the box (as phrase or individual words), mime type or attachment icon. If this is a duplicate PLEASE add some or all of these keywords to the bug to resolve dupes.

Comment 1

11 years ago
Sure the mime type of the incoming mails aren't just wrong?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 255338
You need to log in before you can comment on or make changes to this bug.