bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Quiting Firefox on a seperate window will close the original firefox window.

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: Charlie Wyse, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.0.12) Gecko/20070718 Red Hat/1.5.0.12-3.el5 Firefox/1.5.0.12 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.0.12) Gecko/20070718 Red Hat/1.5.0.12-3.el5 Firefox/1.5.0.12 pango-text

If you have a 2 head display and open a firefox.  Then open another firefox window and move it to the other screen.  When you go to quit firefox on the second window it will bring up the quit for firefox on the first window.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox, make a few tabs
2.Open another Firefox, with no tabs
3.On the second Firefox (the one with no tabs) go to File -> Quit
4.This will bring up the quit menu box for the original Firefox with the number of tabs you created.
Actual Results:  
It closes the wrong Firefox.

Expected Results:  
It should open a quit menu for the Firefox you clicked on File -> Quit.  Then allow you to quit that firefox.

You cat press Alt-F4 or click on the X in the top right corner and it will close the correct firefox.  This is really a clone of 234819 which was closed incorrectly because it got linked to a different bug.  When that bug was closed it got closed as well but the issue is still there.
It's one instance. By choosing Quit from the File menu the program will be exited. It doesn't matter how many windows are open. If you wanna have your described behavior you have to run a second Firefox instance by using the -no-remote command line argument and a secondary profile created.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Version: unspecified → 1.5.0.x Branch
You need to log in before you can comment on or make changes to this bug.