nsDOMSelection::ToString with OutputSelectionOnly is busted

VERIFIED FIXED in M16

Status

()

Core
Editor
P2
critical
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Charles Manske, Assigned: mjudge)

Tracking

({regression})

Trunk
x86
Windows NT
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][dogfood-])

(Reporter)

Description

18 years ago
The output is busted when trying to use "selection only". 
Use the Composer menu item Debug | Test Selection to  see that the entire 
document is outputed, not just the selection.  I traced into the selection code 
and it seems to call:
encoder->Init(doc, aFormatType, aFlags); 
correctly

Comment 1

18 years ago
Turns out Mike changed this to call new code in nsSelection, which doesn't work
for anything less than the full root node.  I'm going to work with Mike to help
him fix it.
Status: NEW → ASSIGNED
Keywords: regression
Target Milestone: --- → M16

Comment 2

18 years ago
Mike said he would check in a fix for this. Reassigning. Also adding some extra gratuitous text because we're testing Ender Lite at the same time. :-)

Also some text after two blank lines.
Assignee: akkana → mjudge
Status: ASSIGNED → NEW
(Assignee)

Comment 3

18 years ago
testing ender-lite wrapping capability. will this wrap properly? I hope so because i would like to check this stuff in!
Status: NEW → ASSIGNED

Comment 4

18 years ago
Testing wrapping capability in non ender lite .. hajsdklf hjskafl hdkjslahf
kjsalf hkjsalf hjsaklf hjksalfh jskalhf jdskal fhkjsal hfjksalh fkjsal
(Assignee)

Comment 5

18 years ago
utput is busted when trying to uutput is busted when trying to uutput is busted when trying to sdaf sadf asfd sdafasdf asfd sdaf afasfd
(Assignee)

Comment 6

18 years ago
sd sdfgsdf gsdfgsdfgsdfgdsf sdfgsdfgsdg sdfgsdfgdsfgdfs sdfgdsfgsdfg dsfgsdfgdg sdfgsdgsdgfdsfg sdfgsdgsdfg sdfgsdfgsdf sdfgsdfgsd
(Assignee)

Comment 7

18 years ago
asdfadfasdfasdf asdfasdf asd fasdfasdfasdf asdfasdfas asdfasdf adsfasdfasdfa asdf asdfasdfa fdasdfasdf sadfasdfasdf asdfasdf

Comment 8

18 years ago
Interrupt.http://bugzilla.mozil la.org/show_bu g.cgi?id=3952 8Sett
inProgram received signal SIGINT, Interrupt.g style: [user-focus: none;
(Assignee)

Comment 9

18 years ago
is this wrapping now? i certainly hope so. gosh if it doesnt i need to do alot more work. doh!
(Assignee)

Comment 10

18 years ago
i didnt type in enough stuff to get it to wrap at ALL! i will type more this must wrap so that i can really test out this output system of ender-lite . i hope akkana got this working!

Comment 11

18 years ago
nominate for beta 2 and dogfood
Keywords: dogfood, nsbeta2
Priority: P3 → P2
Target Milestone: M16 → M17

Comment 12

18 years ago
setting back to m16 -- my mistake
Target Milestone: M17 → M16

Comment 13

18 years ago
Not clear to PDT whay a blocker.  What is the user problem here?   Needed for 
dogfood, or can we do nsbeta2+?
Whiteboard: [NEED INFO]

Comment 14

18 years ago
Launch the app with the console trigger set (on win32 create a shortcut to the 
desktop, highlight the shortcut, right-click, and select properties, in the 
Target field append -console). Bring up the mozilla home page, and select 
EditPage. In Composer, select some text, then select Debug|Test Selection -- 
what you will see in the console is the entire page scroll past 3 times. 
This manifests itself to the end user when they select text within a table -- 
the paste operation will paste the sleection 3 times, there are certainly other 
situations where this will appear. This bug is a blocker for bug 40457, which is 
the triple paste problem with tables
Depends on: 40457
(Reporter)

Comment 15

18 years ago
This method is used in many places in the editor to get the selected text:
1. user selects text to create a link around it.
2. selected text that is to be edited in the Insert | HTML Source dialog.
3. as the suggested name for Insert | Named Anchor.
4. to copy the text or selected table cells to the clipboard.
In all cases we get the entire document instead of just the selection. This is
very confusing to the user.

Updated

18 years ago
No longer depends on: 40457

Updated

18 years ago
Blocks: 40457

Comment 16

18 years ago
Putting on [nsbeta2+][dogfood-] radar.  Does not need a fix ASAP for daily work, 
but we should fix this for beta2.
Whiteboard: [NEED INFO] → [nsbeta2+][dogfood-]

Updated

18 years ago
Blocks: 41309
(Assignee)

Comment 17

18 years ago
fix in hand.
(Assignee)

Comment 18

18 years ago
should be fixed. check it out charlie..
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Charley, can you verify this one? thanks!
(Reporter)

Comment 20

18 years ago
The string output routine is busted (bug 41814) today, so I can't verify this
yet.

Comment 21

18 years ago
Charley is gonna help me verify this one.
(Reporter)

Comment 22

18 years ago
Looks good to me - Mike fixed all the problems we had with this.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 23

18 years ago
*** Bug 43584 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.