Attendee icons in Free Busy Pane need tooltips to be understandable

VERIFIED FIXED in 1.0b1

Status

Calendar
General
VERIFIED FIXED
11 years ago
6 years ago

People

(Reporter: cmtalbert, Assigned: ssitter)

Tracking

Sunbird 0.7
1.0b1

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
When using the Free Busy Pane the user has no idea what the little icons are for attendees.  A tool tip that appears when the mouse hovers over the attendee icon will help the user to make the proper icon determination for the attendee.

I'm also not sure how accessible these tooltips would be and so we might want to be certain that this information can be relayed in an accessible fashion.
Component: General → Theme
Product: Calendar → Firefox
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
Oops, sorry, my bad, returning to the right component, awfully sorry about stomping your target milestone, please send hatemail to this address :(
Component: Theme → General
Product: Firefox → Calendar
Target Milestone: Firefox 3 → ---
Version: Trunk → Sunbird 0.7
(Assignee)

Updated

10 years ago
Duplicate of this bug: 458575
(Assignee)

Comment 3

9 years ago
Created attachment 376271 [details]
proposal: show role icons with description in legend area
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #376271 - Flags: ui-review?(clarkbw)
Comment on attachment 376271 [details]
proposal: show role icons with description in legend area

That looks decent.  I would evenly space them out between the different columns, they are a bit too close together.

Also simple tooltips with that same text will improve things as well.
Attachment #376271 - Flags: ui-review?(clarkbw) → ui-review+
(Assignee)

Comment 5

9 years ago
Created attachment 378376 [details] [diff] [review]
show role icons with description in legend area

This patch implements the proposed solution, or at least the functional aspect of it. I'd appreciate if someone else volunteers to make it look better or if someone else volunteers to add tooltips.
Attachment #378376 - Flags: review?(philipp)
Summary: [Proto] Attendee icons in Free Busy Pane need tooltips to be understandable → Attendee icons in Free Busy Pane need tooltips to be understandable
Comment on attachment 378376 [details] [diff] [review]
show role icons with description in legend area

Looks fine codewise, I believe this needs ui-r though.
Attachment #378376 - Flags: ui-review?(clarkbw)
Attachment #378376 - Flags: review?(philipp)
Attachment #378376 - Flags: review+
Comment on attachment 378376 [details] [diff] [review]
show role icons with description in legend area

Oops, sorry, it already has ui-r
Attachment #378376 - Flags: ui-review?(clarkbw)
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/34f44faae49c>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Updated

9 years ago
Blocks: 498587

Updated

8 years ago
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.