Turn on caching of widget changes

RESOLVED DUPLICATE of bug 238493

Status

()

Core
Layout: View Rendering
P4
normal
RESOLVED DUPLICATE of bug 238493
18 years ago
13 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: Kevin McCluskey (gone))

Tracking

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
There are a number of bugs which are the result of nsIWidget's instances being 
positioned multiple times during reflow. evaughan@netscape.com built a mechanism 
which caches the widget changes and applies the changes when caching is turned 
off. He found a number of problems when he turned it on initially. These 
problems need to be resolved before it can be turned on permanently.

I was able to fix a number of bugs by adding the following code to 
nsTableOuterFrame.cpp and enabling widget caching in nsViewManager2.

 nsCOMPtr<nsIViewManager> vm;
  nsCOMPtr<nsIPresShell> shell;
  aPresContext->GetShell(getter_AddRefs(shell));

  if (shell) {
    shell->GetViewManager(getter_AddRefs(vm));
    if (nsnull != vm) {
      vm->CacheWidgetChanges(PR_TRUE);
    }
  }

  ...

  if (nsnull != vm) {
    vm->CacheWidgetChanges(PR_FALSE);
  }

After discussing it with Eric, we decided to wait for the general solution 
instead of checking this local widget caching since anything within the table 
may exhibit the problems he saw when he turned on the global widget change 
caching.
(Assignee)

Updated

18 years ago
Blocks: 37039
(Assignee)

Updated

18 years ago
Blocks: 34860

Comment 1

18 years ago
This has to do with that widget caching I was talking about.
Assignee: evaughan → garyf

Comment 2

18 years ago
back to evaughan
Assignee: garyf → evaughan

Comment 3

18 years ago
mass-moving all evaughan non-nsbeta3+ bugs to 'Future' milestone 
(per trudelle). 
Target Milestone: --- → Future
(Assignee)

Comment 4

17 years ago
Taking this bug
Assignee: eric → kmcclusk
(Assignee)

Comment 5

16 years ago
Build moving all existing future-P3 bugs to future-P4.
Priority: P3 → P4
Well, this just seems like a duplicate of bug 238493 to me, so marking it as duplicate. This is fixed anyway.

*** This bug has been marked as a duplicate of 238493 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.