ForeCastFox extension unable to display Icons

VERIFIED FIXED in mozilla1.9alpha8

Status

()

VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: jmjeffery, Unassigned)

Tracking

({regression})

Trunk
mozilla1.9alpha8
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007090717 Minefield/3.0a8pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007090717 Minefield/3.0a8pre Firefox/3.0

With the extension ForecastFox installed the icons cannot be displayed in any area of the browser.  Most common place is in the statusbar.

Reproducible: Always

Steps to Reproduce:
1. Install a Minefield build dated 20070907 13:00Hrs or later
2. Note the icosns are not displayed for ForecastFox
3.


Expected Results:  
Icons for ForecastFox should display with the extension installed.

Bonsai checkins:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-09-07+05%3A00%3A00&maxdate=2007-09-07+13%3A00&cvsroot=%2Fcvsroo

I would guess maybe https://bugzilla.mozilla.org/show_bug.cgi?id=394397 make cut/copy/paste menus sticky
https://bugzilla.mozilla.org/show_bug.cgi?id=395188 Fix crash if a paused download is stopped 

395188 does not seem logical to me - as the bad guy here.
(Reporter)

Updated

11 years ago
Keywords: regression
Version: unspecified → Trunk
Errors in console:

Error: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIObserverService.addObserver]
Source file: chrome://forecastfox/content/utilities/manager-service.js
Line: 331


This is from simple calls to observerservice.addObserver(this, ..., ...)

The "this" object does not have a QueryInterface implementation but does something weird, it adds interfaces to this._ifaces in its contructor. Not come across that before, but _ifaces appears to be a magically existing array on the object since it isnt declared anymore. Maybe this is some xpconnect magic I don't know of.

A local backout confirms this was caused by bug 395256
Blocks: 395256
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → XPConnect
Product: Firefox → Core
QA Contact: general → xpconnect
Created attachment 280143 [details]
manager-service

This is the code for the object that tries to add register itself with the observer service. Line 331 is the filing line, just text search for addObserver, it's the first one.
Fixed by the backout of the patch for bug 395256. Can someone please verify?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M8
V. FIXED.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007090719 Minefield/3.0a8pre ID:2007090719
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.