Several date test failures when not using standard time zones (bad tests?)

RESOLVED DUPLICATE of bug 1089745

Status

()

RESOLVED DUPLICATE of bug 1089745
11 years ago
10 months ago

People

(Reporter: swaroopch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: http://hg.mozilla.org/actionmonkey/

When I run the SpiderMonkey test suite ( as detailed at http://developer.mozilla.org/en/docs/SpiderMonkey_Build_Documentation#Test ), then I get lot of date test failures. jorendorff suggests that it might be because I'm in the India time zone (GMT+0530 hours).

Reproducible: Always

Steps to Reproduce:
1. Set time zone to IST (GMT+0530)
2. Run the SpiderMonkey test suite (http://developer.mozilla.org/en/docs/SpiderMonkey_Build_Documentation#Test)
Actual Results:  
Example failures are:

*-* Testcase ecma/Date/15.9.3.1-2.js failed:

Failure messages were:
new Date( 1999,11,31,15,59,59,999).getUTCMinutes() = 29 FAILED! expected: 59
new Date( 1999,11,31,16,0,0,0).getUTCMinutes() = 30 FAILED! expected: 0
new Date( 1999,11,31,23,59,59,999).getUTCMinutes() = 29 FAILED! expected: 59
new Date( 2000,0,1,0,0,0,0).getUTCMinutes() = 30 FAILED! expected: 0
new Date( 2000,0,1,0,0,0,1).getUTCMinutes() = 30 FAILED! expected: 0

*-* Testcase ecma/Date/15.9.3.8-5.js failed:

Failure messages were:
new Date(-2208988800000).getMinutes() = 30 FAILED! expected: 0
new Date(-2208960000000).getMinutes() = 30 FAILED! expected: 0
new Date("Mon Jan 01 1900 05:30:00 GMT+0530 (IST)").getMinutes() = 30 FAILED! expected: 0
new Date("Mon Jan 01 1900 13:30:00 GMT+0530 (IST)").getMinutes() = 30 FAILED! expected: 0
new Date("Mon, 01 Jan 1900 00:00:00 GMT").getMinutes() = 30 FAILED! expected: 0
new Date("Mon, 01 Jan 1900 08:00:00 GMT").getMinutes() = 30 FAILED! expected: 0


Expected Results:  
There should be no date test failures.

Perhaps these are faulty tests, since I highly doubt the JavaScript engine's date class is bad!
(Reporter)

Comment 1

11 years ago
Created attachment 280167 [details]
The entire list of failures reported by the test suite
(Reporter)

Comment 2

11 years ago
Created attachment 280168 [details]
The entire list of failures reported by the test suite
Attachment #280167 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Assignee: general → nobody

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089745
You need to log in before you can comment on or make changes to this bug.