open in new window wastes time in GC.

VERIFIED DUPLICATE of bug 42321

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 42321
18 years ago
18 years ago

People

(Reporter: Marko Macek, Assigned: jst)

Tracking

({perf})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

186.65 KB, application/octet-stream
Details
(Reporter)

Description

18 years ago
Attached jprof seems to show a lot of time being wasted in JS_GC when I am
opening new windows (opened several dozen in a row).

How can we get rid of (reduce) GC calls in SetNewDocument and SetupNewViewer?

The default page is about:blank.

See also bug 28639 (closing windows), and 30660.
(Reporter)

Comment 1

18 years ago
Created attachment 8765 [details]
jprof output (.ZIP!)
(Reporter)

Updated

18 years ago
Keywords: perf
(Reporter)

Comment 2

18 years ago
Opening windows also gets slower and slower. First window takes about 0.3
seconds (time displayed status line), window 31 took 2 seconds to open.

Comment 3

18 years ago
Please also test bug 27574 if this gets fixed.  Good catch Marko!

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Reassigning to get some insight into the problem
Assignee: adamlock → rogerl
Component: Embedding: Docshell → Javascript Engine
QA Contact: adamlock → pschwartau
(Reporter)

Comment 5

18 years ago
I suggest marking it depend on 42321 (perhaps some others mentioned there too).

Comment 6

18 years ago
As was done with related bug 42321, would like to redirect to DOM Level 0 -
 
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale
(Assignee)

Comment 7

18 years ago
We should really try to reduce the calls to GC when opening new windows,
nominating for beta3. I had a quick look and it looks like we're calling GC 3
times for every new document we load or for every new window we open, seems like
once would be enough.
Status: NEW → ASSIGNED
Keywords: nsbeta3
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Future
(Assignee)

Comment 8

18 years ago
This is coverd by bug 42321 (nsbeta3+), duping.

*** This bug has been marked as a duplicate of 42321 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.