Formfield Autocompletion - When mouse is in the AC box mouse-over will activate item upon hitting enter

RESOLVED DUPLICATE of bug 376868

Status

()

--
minor
RESOLVED DUPLICATE of bug 376868
11 years ago
11 years ago

People

(Reporter: imqqmi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Summary says it all. When in google.com, entering a search, my mousepointer is often under the search formfield, when autocompletion appears one of the items are highlighted by the mousepointer (without moving the mouse) upon hitting enter it will take the highlighted autocomplete item (which is not wanted most of the time). I end up retyping my search string because I constantly activate a autocomplete item by accident.

Reproducible: Always

Steps to Reproduce:
1. Place mouse pointer under the search field in google
2. enter a search string that will show the autocompletion list 
3. the item under the mouse gets highlighted and activated upon hitting enter
Actual Results:  
The result is that I get a search I did not want and have to retype the search string. 


The interface logic should be something like this:
When a user enters a string in a formfield, the placement of the mouse pointer/arrow should have no effect on the data entered. It should at least ignore the autocompletion list (upon hitting enter) until the mouse is moved, or maybe even better, when the user actually clicks on the autocompletion item of choice. So disable mouseover activation of an item on the autocompletion list.
I think this is a duplicate of Bug 376868 although I believe there is also another similar bug, but I can't find it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376868
You need to log in before you can comment on or make changes to this bug.