Exception... "Invalid ClassID or ContractID" for nsInterfaceInfoToIDL.js when starting trunk

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: STR in comment #2)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Steps to reproduce:

0. Get a mac, XCode, setup mozconfig, with --enable-debug
1. Check out using make -f client.mk checkout
2. Build using make -f client.mk build to an objdir
3. Get a ChatZilla app bundle from http://cz.rdmsoft.com/xr/
4. Attempt to install the app bundle using:
path/to/objdir/dist/XUL.framework/xulrunner-bin --install-app path/to/chatzilla-xpi-file

Expected result:
No errors.

Actual result:

JS Component Loader: ERROR (null):0
uncaught exception: [Exception... "Invalid ClassID or ContractID" nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)" location: "JS frame :: file:///Users/gijskruitbosch/moz_dev/builds/xulrunner-debug-i386-apple-darwin8.10.1/dist/XUL.framework/Versions/1.9a8pre/components/nsInterfaceInfoToIDL.js :: <TOP_LEVEL> :: line 45" data: no]


The application is still installed, but in Finder it has a big no access sign over the icon (http://images.google.nl/images?q=no%20access%20sign). Starting it seems to do nothing. This might be caused by other xulrunner problems, though - I can't tell (given there is no documentation on this stupid no access sign, or on why the app will not start at all, or on how xulrunner works on mac).

PS: this might be the wrong component, but I can't tell where else it should go at the moment.
(Reporter)

Comment 1

11 years ago
For now I'm assuming this is a dupe because of the non-libxul mess that existed a few months ago. If anyone manages to repro this, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395586
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007120900 Minefield/3.0b2pre

As far as I can see this cannot be a dupe of bug 395586. The exception is still happening for the latest official Firefox nightly builds on OS X. Just start up Firefox and have a look into the Error Console. Further I get following error:

Error: Warning: unrecognized command line flag -foreground

Source File: file:///Users/henrik/Projects/mozilla/bin/Minefield.app/Contents/MacOS/components/nsBrowserContentHandler.js
Line: 660

How the product/component should be handled? Asking for blocking1.9.
Status: RESOLVED → REOPENED
Flags: blocking1.9?
Resolution: DUPLICATE → ---
Version: unspecified → Trunk
(Reporter)

Comment 3

11 years ago
Doing a best guess thing.
Status: REOPENED → NEW
Component: XULRunner → XRE Startup
QA Contact: xulrunner → xre.startup
Summary: Exception... "Invalid ClassID or ContractID" for nsInterfaceInfoToIDL.js on trunk xulrunner → Exception... "Invalid ClassID or ContractID" for nsInterfaceInfoToIDL.js when starting trunk
Whiteboard: STR in comment #2
Sounds like nsBrowserContentHandler needs to handle "-foreground" for that error message, but I don't see any invalid ClassID/ContractID error...  Can you give steps to reproduce the CID error?  I'm not even sure what that's error's referring to.
Flags: blocking1.9? → blocking1.9-
Vlad, I don't have to give any steps. It happens at a time while starting Firefox. When I open the Error console the exception and error is already listed. No idea if both messages belongs together because there is a further information between:

Failed to load XPCOM component: /Users/henrik/Projects/mozilla/bin/Minefield.app/Contents/MacOS/components/nsInterfaceInfoToIDL.js

So -foreground could be another issue?

Comment 6

10 years ago
I get the same (or a similar error).

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/geert/.thunderbird/4hfxktwk.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/geert/.thunderbird/4hfxktwk.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67
Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/today-pane.js :: <TOP_LEVEL> :: line 46"  data: no]
Error: uncaught exception: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: chrome://lightning/content/lightning-utils.js :: <TOP_LEVEL> :: line 81"  data: no]

And it goes on like this with at least 20+ more errors.

I am using Lightning 0.7 on Thunderbird 2.0.0.9 on Fedora 8 on i386. The problem can be reproduced on a clean system under a user-account with no-pre-existing thunderbird profile:

 - Install Fedora 8 from DVD
 - Install thunderbird if not already installed (yum -y install thunderbird)
 - Install Lightning 0.7 with the XPI (tools -> add ons -> install)

The calendar view is also garbled. The grid messed up, and the mode selector uses a pane that spans from the bottom of the window to the top. I have attached a screenshot as well.

The error can be reproduced on a clean Fedora 8 system. Just install from the DVD, install Thunderbird, add the 

Comment 7

10 years ago
Created attachment 303995 [details]
Screenshot of Lightning showing garbled layout
(In reply to comment #6)
Geert, you are seeing a completely different issue. Either use a Lightning build for you system or install the required libstdc++5 library ("compat-libstdc++" on Fedora IIRC) if you are using the .xpi from mozilla.org. (I recommend to try the support forum or support newsgroup first next time).

Updated

10 years ago
Component: XRE Startup → Startup and Profile System
QA Contact: xre.startup → startup
(Reporter)

Comment 9

9 years ago
I haven't seen this in ages, can't reproduce anymore as it is right now, etc.. WFM, feel free to reopen if this bug is still around.
Status: NEW → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.