If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

File deleted after download

VERIFIED DUPLICATE of bug 191239

Status

()

Toolkit
Downloads API
--
minor
VERIFIED DUPLICATE of bug 191239
10 years ago
9 years ago

People

(Reporter: Teppo Kauppinen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

When a link to a file is clicked and "Open with" selected (IZArc in my case) and during the download the browser is closed (but download manager still left running), the downloaded file is deleted when downloading ends. I can see the folder that the archive contains but I cannot unzip it nor can IZArc show me the contents of the zipped folder. When I close IZArc and open firefox => downloads => select the file I just downloaded => open, I get error message saying "file does not exist". When I download the file again, the archive is just fine.

This has happened to me with many different firefox versions during last months / year.

This cannot be wanted behaviour as the download continues and the download manager is displayed when the browser window is closed. It's very annoying to realize that after waiting 2 hours to download something from rapidshare, firefox somehow manages to delete the file when downloading ends.

Reproducible: Always

Steps to Reproduce:
1. make sure download manager is displayed during download and will be hidden when download ends
2. download zip-file 
3. use open with
4. kill main browser window
5. try to use the archived file(s) after download ends
Actual Results:  
archive seems to be empty

Expected Results:  
contents of archive should be displayed
open with just saves the file temporarily
Whiteboard: DUPEME?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 191239
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.