colliding event boxes in rotated calendar view

VERIFIED FIXED in 0.7

Status

Calendar
Calendar Views
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Andreas Treumann, Assigned: Michael Büttner (no reviews TFN))

Tracking

unspecified

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 280333 [details]
test *.ics file

STEPS TO REPRODUCE:
===================

- create a new calendar
- import the attached *.ics file
- change to the week view
- rotate calendar view

RESULT:
=======

- colliding event boxes (event '1' and '2')

EXPECTED RESULT:
================

- the events should not colliding

REPRODUCIBLE:
=============

- always

Comment 1

11 years ago
Confirming also with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070908 Calendar/0.7pre
OS: Solaris → All
Hardware: Sun → All
Version: Trunk → unspecified
(Reporter)

Comment 2

11 years ago
I set the 0.7? flag because this bug is a regression.
Flags: blocking-calendar0.7?
(Reporter)

Comment 3

11 years ago
I remove the 0.7? flag because the rotate view button is gone and the functionality isn't so prominent anymore.
 
Flags: blocking-calendar0.7? → blocking-calendar0.7-
(Assignee)

Comment 4

11 years ago
Created attachment 281190 [details] [diff] [review]
patch v1

Erroneously, I didn't take the orientation into account when the new layout code finally constructs the different columns. This patch does the trick.
Assignee: nobody → michael.buettner
Status: NEW → ASSIGNED
Attachment #281190 - Flags: review?(daniel.boelzle)

Comment 5

11 years ago
Comment on attachment 281190 [details] [diff] [review]
patch v1

r=dbo
Attachment #281190 - Flags: review?(daniel.boelzle) → review+
(Assignee)

Comment 6

11 years ago
patch checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
(Reporter)

Comment 7

11 years ago
Checked in Lightning (build 2007091903) and Sunbird (build 20070919) -> VERIFIED
Status: RESOLVED → VERIFIED

Updated

10 years ago
Flags: blocking-calendar0.7-
You need to log in before you can comment on or make changes to this bug.