Seemingly random crash when composing or reading [@ JS_strtod]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Michael Blinn, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.12) Gecko/20070718 Fedora/1.5.0.12-4.fc6 Firefox/1.5.0.12
Build Identifier: version 2.0.0.6 (20070728)

Multiple Win98 boxes display this error when opening a mail for reading or composing a message. Crash is 'exception 10h' in module JS3250.dll - Continues to occur after profile wipe, and even after format & reinstall of OS. Most frequent offender is on 250MB IMAP account, but of 50 computers with TB2, 10 or 15 have displayed this error at some point. Crash occurred in TB1.5.0.* and followed upgrade to TB2

Reproducible: Sometimes

Steps to Reproduce:
1. Sometimes when reading mail in 3-window mode, preview pane below
2. Sometimes while composing message

Actual Results:  
Many days there will be 5-6 crashes in one day, with OS restart after each one. Some times it will be days or a week between crashes.


Crash occurred in TB1.5.0.* and followed upgrade to TB2 Crash is 'exception 10h' in module JS3250.dll DrWatson initially pointed to KB* Microsoft patches, but crash continues after patch removal and DrWatson doesn't provide any helpful debugging information.

http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB35619249H
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

11 years ago
Michael, what do you think of bug 334263?


TB35619249H
Stack Signature	 JS_strtod 53e237be
Product ID	Thunderbird2
Build ID	2007072817
Trigger Time	2007-09-05 10:47:03.0
Platform	Win32
Operating System	Windows 98 4.10 build 67766446
Module	JS3250.DLL + (000109cc)
ince Last Crash	109245 sec
Total Uptime	631261 sec
Trigger Reason	Invalid operation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8-Release/WINNT_5.0_Depend/mozilla/js/src/jsdtoa.c, line 1243
Stack Trace 	
JS_strtod  [mozilla/js/src/jsdtoa.c, line 1243]
js_strtod  [mozilla/js/src/jsnum.c, line 938]
js_ValueToNumber  [mozilla/js/src/jsnum.c, line 757]
num_isNaN  [mozilla/js/src/jsnum.c, line 73]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1375]
js_Interpret  [mozilla/js/src/jsinterp.c, line 3946]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1394]
nsXPCWrappedJSClass::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1453]
nsXPCWrappedJS::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
SharedStub  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsMsgStatusFeedback::OnStateChange  [mozilla/mailnews/base/src/nsMsgStatusFeedback.cpp, line 176]
nsDocLoader::FireOnStateChange  [mozilla/uriloader/base/nsDocLoader.cpp, line 1210]
nsDocLoader::doStopDocumentLoad  [mozilla/uriloader/base/nsDocLoader.cpp, line 844]
nsDocLoader::OnStopRequest  [mozilla/uriloader/base/nsDocLoader.cpp, line 665]
nsLoadGroup::RemoveRequest  [mozilla/netwerk/base/src/nsLoadGroup.cpp, line 732]
PresShell::RemoveDummyLayoutRequest  [mozilla/layout/base/nsPresShell.cpp, line 7190]
DummyLayoutRequestEvent::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 7090]
0x778b0c24
Keywords: crash
Summary: Seemingly random crash when composing or reading - sorry so vague! → Seemingly random crash when composing or reading [@ JS_strtod]
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Michael, what do you think of bug 334263?

334263 seems to be related to some additional software which is causing the conflicts (AllChars/AceClock). My boxes are under strict control - Firefox, IE6, Office97, Symantec Antivirus Corporate, Acrobat Reader 6 and HP JetDirect are the only other applications on these boxes beside the OS. This bug still occurs with the AV engine turned off, as well as completely uninstalled.

-Michael

Comment 3

11 years ago
i don't know much about jet direct, but it's definitely not a standard process, you might consider trying w/ it uninstalled.

Assignee: nobody → general
Component: Mail Window Front End → JavaScript Engine
Product: Thunderbird → Core
QA Contact: front-end → general
Version: 2.0 → 1.8 Branch
(Reporter)

Comment 4

11 years ago
Jetdirect is the only method i know of for adding TCP/IP printer ports in Win98 and communicating with dedicated print servers. Regardless, this bug is not manifested when printing, just when composing or reading email, preview-pane activated.

Comment 5

11 years ago
if you'd read the allchars bugs, you'd see that it has nothing to do with actions, and everything to do with in memory presence. please try it.

(it'd also be nice if you could run msinfo and give a complete list of running processes/loaded libraries.)
Reporter, are you able to come-up with the requested information? Otherwise it will be closed as INCOMPLETE soon.
Whiteboard: CLOSEME 02/06
(Reporter)

Comment 7

11 years ago
Upgrading to Thunderbird 2.0.0.9 resolved this issue. "Thank you" to the team!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Whiteboard: CLOSEME 02/06
Crash Signature: [@ JS_strtod]
You need to log in before you can comment on or make changes to this bug.