Printing takes a very long time, very large spool files are generated

RESOLVED DUPLICATE of bug 377336

Status

()

Core
Printing: Output
--
major
RESOLVED DUPLICATE of bug 377336
11 years ago
11 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows XP
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
This came up as a forums topic:
http://forums.mozillazine.org/viewtopic.php?t=581611&sid=a41cc1a0f747334917655818cc85b686

For me, the printing, or the preparing to print doesn't take that much time, but I still get a very large spool file of appr. 240MB, while branch builds use appr. 40MB.
Maybe, if you don't have that much memory in your computer, then it will a considerable longer time?

This regressed between 2007-02-06 and 2007-02-07, I think a regression from bug 177805, somehow.

I have only tested with philly.com, but according to the mozillazine topic there are more pages that suffer from this.
Flags: blocking1.9?

Comment 1

11 years ago
For comparison :

HP Laserjet 4100 (PCL mode)
2.0.0.6      : 1.143KB
latest trunk : 6.688KB

HP Business Inkjet 2250 (PS mode)
2.0.0.6      : 2.534KB
latest trunk : 7.443KB

I have written PostScript before, I'll try to make sense of the difference. My first reaction (sorry I have to leave within a minute), is that the images are much larger. And that all text is send as images to the printer. Must be a side effect of the Cairo library (transparency, anti-aliasing, ...). There are no fonts included anymore.

Comment 2

11 years ago
Dupe of bug 362325 probably, although that one is only looking at performance (and originally filed for the Mac). But these big files might be one of the reasons that printing is slow.
(Reporter)

Comment 3

11 years ago
Note that bug 362325 was filed before this regressed.
I can clearly see this regressed between 2007-02-06 and 2007-02-07, where the latter dated build takes up >400MB as spool file (making my computer miserable).
In current trunk builds, it's not as bad, just appr. 240MB, as I said.

Comment 4

11 years ago
how about bug 377336?

Comment 5

11 years ago
IMVHO it is actually bug 378307. Printing pages which doesn't make cairo to use image fallbacks is almost equally fast as with branch builds.
(Reporter)

Comment 6

11 years ago
Ok, thanks, there are already quite a few bugs that handle the same issue (and have blocking1.9+). I'm duping it against bug 377336 for now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 377336
You need to log in before you can comment on or make changes to this bug.