If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect rendering of floats (regression)

VERIFIED WORKSFORME

Status

()

Core
Layout
VERIFIED WORKSFORME
10 years ago
8 years ago

People

(Reporter: FataL, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091005 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091005 Minefield/3.0a8pre

ul {
  font-size: 120%;
  float: left;
  overflow: hidden;
  }

ul li {
  float: left;
  padding-right: 1em;
  }

<ul>
  <li>Item1</li>
  <li>Item2</li>
</ul>

List items should be rendered in one horizontal line.
Firefox 3 seems has regression and list items break in two lines, with last item always placed in second line.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Firefox 3 seems has regression and list items break in two lines, with last item always placed in second line.

Expected Results:  
List items should be rendered in one horizontal line.

This bug affects CSS layout that I created.
Created attachment 280366 [details]
testcase from reporter's URL

Updated

10 years ago
Keywords: testcase
Version: unspecified → Trunk
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Is a regression on 20 July 2007, from bug 384876.
Blocks: 384876
Flags: blocking1.9?
Works for me on trunk.  Is this still a problem for others?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007100314 Minefield/3.0a9pre ID:2007100314
Looks like this is a WFM now. The testcase shows all three items on the same line.

Comment 5

10 years ago
WFM on OS X trunk builds.
Flags: blocking1.9? → blocking1.9+
WFM on Linux trunk build.  Resolving as WFM.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.